The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

redmine error?

Discussion in 'General Discussion' started by raggi5, Jun 3, 2011.

  1. raggi5

    raggi5 Registered

    Joined:
    Jun 3, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I am having major roadblocks trying to get redmine installed, the biggest being in cpanel...

    Code:
    Your app is NOT installed because there was a problem. Try again or contact our support team.
    Show Details
    
    No supported version of rails found. 
    yet i have tried to install rails 2.3.5 by this command:
    Code:
    gem install rails -v=2.3.5
    Really need soem help here!
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Has ruby and rails been installed on the machine itself using /scripts/installruby previously?

    If so, what do these return:

    Code:
    ruby -v
    rails -v
     
  3. raggi5

    raggi5 Registered

    Joined:
    Jun 3, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Code:
    root@cp2 [~]# ruby -v
    ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-linux]
    root@cp2 [~]# rails -v
    Rails 3.0.7
    root@cp2 [~]#
    
    That is what is returned
     
  4. raggi5

    raggi5 Registered

    Joined:
    Jun 3, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I believe redmine requires 2.3.5 on rails... so i dont know why i cant rollback to 2.3.5
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    cPanel will use the latest version of Rails installed server-wide, which appears to be 3.0.7 on your system. cPanel + mongrel will not work on Rails 3, so until Rails 3 has been uninstalled, you will not be able to install any applications using cPanel > Ruby on Rails area.

    Code:
    gem uninstall rails
    gem uninstall actionmailer
    gem uninstall activemodel
    gem uninstall actionpack
    gem uninstall activerecord
    gem uninstall activeresource
    gem uninstall activesupport
    gem uninstall railties
    gem install rails -v=2.3.11
    The current version of Rails required by cPanel is Rails 2.3.11. After you've installed that, then you should be able to generate applications in cPanel > Ruby on Rails area. After that, you can still have a local copy of 2.3.5 if you want and you can see if it exists by doing this command (after you've removed Rails 3.0.7):

    Code:
    gem list --local | grep -i rails
    You should get a return such as the following after you've properly installed Rails 2.3.11 and uninstalled Rails 3.0.7:

    Code:
    [~]# gem list --local | grep -i rails
    rails (2.3.11, 2.3.5)
     
  6. tomdchi

    tomdchi Well-Known Member

    Joined:
    Feb 24, 2008
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    cPanel Access Level:
    DataCenter Provider
    I am having the same problem when trying to create a ruby application in cpanel.

    Code:
    No supported version of rails found. 
    ruby and rails version:
    Code:
    root@rps-server1 [~]# ruby -v
    ruby 1.8.7 (2011-02-18 patchlevel 334) [x86_64-linux]
    root@rps-server1 [~]# rails -v
    Rails 2.3.11
    
    Code:
    root@rps-server1 [~]# gem list --local | grep -i rails
    rails (2.3.11)
    
    Any ideas?
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    This was already explained to you in the other thread. In fact, this thread even showed you that you can have multiple versions of Rails installed and cPanel will pick up the latest installed version.

    http://forums.cpanel.net/f5/ruby-rails-issue-222852.html

    Please do not make multiple posts about the same issue.
     
Loading...

Share This Page