The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Regex not working as expected with Global Mail Filters

Discussion in 'E-mail Discussions' started by DeepXP, Nov 15, 2015.

  1. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    I am trying to create a filter which would accept any email with a specific pattern. I created a filter using regex, tested it, matched the filter rules successfully. But it bounces back the email when when I send the mail.

    Here is what I am trying to achieve:

    Any mail sent to unsubscribe+(random characters)@example.com should get delivered to test@example.com

    So my filter looks like this:

    To
    Matches regex
    unsubscribe+(.*?)+?@example.com
    Redirect to Email
    test@example.com

    Get "550 No Such User Here" error for unsubscribe+abc123@example.com when the actual email is sent.

    Any idea what could be the reason?

    I am on 11.52.0 (build 22) version of WHM
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page