Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Register Global problem

Discussion in 'Workarounds and Optimization' started by calvinphanctt, May 2, 2012.

  1. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    156
    Dear all,

    When my WHM upgraded to the new PHP, one of my website got a warning like this, could you please tell me how to fix it ? I don't want to enable the register_global on.

    Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively in Unknown on line 0


    Thank you very much.

    Sincerely,
    Calvin
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Did you try setting "session.bug_compat_warn = off" in your php.ini file as it suggests doing?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. calvinphanctt

    calvinphanctt Active Member

    Joined:
    Mar 27, 2007
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    156
    Hi Tristan,

    It doesn't tell me which files has "session.bug_compat_warn" . What should I do ?

    On the other hand, I just upload one file call php.ini which contained a line "register_globals = on", that message disappeared. However, sometime later when I came back, that warning message appears again ! And if I refresh that message will go away. What is wrong here ?

    Please help ! Thank you so much!

    Sincerely,
    Calvin
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The setting would go into either the global php.ini at /usr/local/lib/php.ini location or into the account php.ini if it is using suPHP and has one.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice