The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Regular "named" failure and won't restart

Discussion in 'General Discussion' started by willke, Apr 19, 2013.

  1. willke

    willke Well-Known Member

    Mar 30, 2005
    Likes Received:
    Trophy Points:

    Every few weeks my "named" falls over and doesn't restart. Same happened last evening. I really would appreciate some help trying to find out why this happens, as I don't really know what to do and my host just tells me to get backup dns.

    I'm getting the error message below.

    nameserver failed @ ***. A restart was attempted automagically.
    Service Check Method: [check command]
    Number of Restart Attempts: 1
    Cmd Service Check Raw Output: named is not running
    Startup Log: Starting named:

    I've looked in var/messages and the last few lines before it fails are shown below

    21:56:10 server automount[4064]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
    21:56:16 server PAM-hulk[4141]: failed to connect stream socket
    21:56:17 server PAM-hulk[4141]: failed to connect stream socket
    21:57:57 server avahi-daemon[5096]: Found user 'avahi' (UID 70) and group 'avahi' (GID 70).
    21:58:03 server avahi-daemon[5096]: Successfully dropped root privileges.
    21:58:11 server /etc/init.d/named: named shutdown failed
    21:58:12 server avahi-daemon[5096]: avahi-daemon 0.6.16 starting up.
    21:58:28 server named[5298]: starting BIND 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.5 -u named
    21:58:28 server avahi-daemon[5096]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!

    Can anyone advise what the problem may be?



Share This Page