The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Reject messages (not bouncing) when mailbox full

Discussion in 'E-mail Discussions' started by mfragoso, Feb 20, 2005.

  1. mfragoso

    mfragoso Active Member

    Joined:
    Oct 17, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Mexico City
    cPanel Access Level:
    Root Administrator
    Hi,

    My spool is getting big with messages trying to notify that the mailbox is full and obviously that sender usually do not exist.

    Is it possible that after a rcpt to and checking that the mailbox is full not to sent a 250 response? I would like a 4xx Mailbox full message after rcpt to and close connection... is that possible?

    Thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The problem as I'd see it is that the quota checking in exim is done after the whole email is received (as otherwise you don't know whether that email will put the mailbox over quota) and so you've lost the chance to deny the email at the RCPT stage as you're now past the DATA stage.

    Checking on the exim mailing list, it looks like this has been discussed at some length and there are also permissions issue with trying to do this at the RCPT stage in exim too. They say quite clearly that it isn't possible to do this in exim.

    One thing to check that you have the following enabled:
    WHM > Exim Configuration Editor > Discard emails for users who have exceeded their quota instead of keeping them in the queue
     
  3. mfragoso

    mfragoso Active Member

    Joined:
    Oct 17, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Mexico City
    cPanel Access Level:
    Root Administrator
    Thanks Jonathan,

    I was afraid that this could not be done. I checked the option you said as well as modified the exim.conf with * quota , and it works partially. For example if i send a mail thru someone with the mailbox full it will not appear on the spool, however there are still some other mails from other recipients (I suspect because they have an alias like info which is then routed to a full mailbox). I also installed you ACL and it is working great.

    I strongly recommend to everyone in this forum the services Jonathan offers. Great solutions and support.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Thanks :)

    One thing that I sometimes see is people of have created a Mail account and a Forwarder so that email is forwarded on and delivered to a mailbox. If that mailbox fills up and the Forwarder bounces for some reason (AOL being stupid as usual or their forwarded email address being full!) it can cause email to build in the queue. The fix for that is obviously to delete the mailbox.
     
Loading...

Share This Page