The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rejected mail due to MX and host name problems

Discussion in 'E-mail Discussions' started by olliemaitland, Feb 20, 2005.

  1. olliemaitland

    olliemaitland Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hi -

    I'm having problems with some emails sent through php that is returning the errors:

    450 Client host rejected: cannot find your hostname, [69.56.169.154]

    I know this has something to do with the problem of reverse DNS look ups but I can't see how to fix this.

    The second error I receive is:

    557 Your domain byng01.byng-designs.com does not have a valid MX DNS record

    Can anyone give me any pointers on how to correct this?

    Thanks.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, I just checked byng01.byng-designs.com and it appears to be setup just fine. ThePlanet have an rDNS PTR record setup for your IP address and your hostname resolves to the same IP.

    Is this a new server and domains could still be resolving, or has it been up and running for at least a few days?
     
  3. olliemaitland

    olliemaitland Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the reply...

    The server has been up for about one year now... DNS should have propagated ;p

    Still not quite sure why I'm recieving the messages - would it be foolish to setup an mx record the same as my host name?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It wouldn't do any harm.
     
  5. micron

    micron Member

    Joined:
    Dec 1, 2002
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    I am having this same problem and would love to know the solution.
     
  6. chinthu

    chinthu Registered

    Joined:
    Jan 16, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    You can disable option "Automatically send outgoing mail from the account's IP address instead of the main IP address" in WHM>>EximConfiguration.
     
Loading...

Share This Page