Ovidiu Sopa

Member
Jun 19, 2017
5
1
3
Sibiu, Romania
cPanel Access Level
Root Administrator
Hello everyone,

I just had a few bad days after migrating about 200 websites from a 5 years old server, to a brand new one that uses Centos 7.6.

I don't know if this issue really can't be solved by a setting in WHM/EXIM but the guys in the datacenter couldn't provide a solution to my clients issue. I have many clients that use their EMAIL CLIENT with SMTP set on port 25 or 26, Connection security set to NONE, and Password transmited unsecurely. Like in the image bellow.

Now, with the new server this setting is generating an error when the EMAIL CLIENT (Outlook, Thudnerbird, Etc..) sends an email to a different server, like yahoo .. or any other different server! But if the email is sent to any account on the same server, there is no issue, the email is sent right away trough port 25 or 26 with password sent insecurely.

With insecure settings if I look in the log file of the server I can see this error message (the email client is set to make an SMTP autentification)

Code:
2019-07-15 14:17:39 SMTP connection identification H= A=94.....50 P=49741 M= U=lucisopa ID=1072 S=ov***[email protected]***l.ro B=recent_authed_mail_ips_domain

2019-07-15 14:17:39 H=([192.168.1.2]) [94.****.50]:49741 F=<o***[email protected]**l.ro> rejected RCPT <ov***[email protected]>: Rejected relay attempt: '94.52.20.50' From: 'ov***[email protected]***l.ro' To: 'o***[email protected]'
And with the mail client set on port 26 or 587 with Connection security : STARTTLS, the same email, the same recipient, is sent just fine to yahoo inbox.
Code:
2019-07-15 14:29:42 1hmzAq-0000iD-95 H=([192.168.1.2]) [94.88888.50]:49883 Warning: "SpamAssassin as cpaneleximscanner detected OUTGOING smtp message as NOT spam (-1.0/60)"
2019-07-15 14:29:42 1hmzAq-0000iD-95 <= ov****[email protected]**ul.ro H=([192.168.1.2]) [94.***.50]:49883 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:eek:***[email protected]***ul.ro S=922 [email protected]***l.ro T="testing from s***l.ro" for o***[email protected]
2019-07-15 14:29:42 1hmzAq-0000iD-95 Sender identification U=l****a D=s****l.ro S=o***[email protected]***l.ro
2019-07-15 14:29:42 1hmzAq-0000iD-95 SMTP connection outbound 1563190182 1hmzAq-0000iD-95 s***ul.ro o***[email protected]
2019-07-15 14:29:47 1hmzAq-0000iD-95 => o***[email protected] R=dkim_lookuphost T=dkim_remote_smtp H=mta5.am0.yahoodns.net [98.137.159.25] X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=yes C="250 ok dirdel"
2019-07-15 14:29:47 1hmzAq-0000iD-95 Completed
So my question again, there really is no setting I can make on this new server, to let my clients use the same software they are used to ? On port 25 and 26 using no connection security?

PS. I haven't opened a new ticket to cPanel support yet.

Thank you.
 

Attachments

Last edited by a moderator:

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @Ovidiu Sopa,

The following option is enabled by default under the Security tab in WHM » Service Configuration » Exim Configuration Manager on new cPanel & WHM installations:

Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server

Here's the description of this option:

Disabling this option will significantly decrease the security of the server by allowing the plaintext transmission of authentication credentials.
While you could disable this option to allow the plaintext transmission of authentication credentials, this is highly discouraged. Instead, the better approach is to provide the Secure SSL/TLS Settings found under cPanel >> Email Accounts >> Connect Devices to any email user still using insecure authentication settings in their client.

Thank you.