The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

relaying problems (outgoing mail)

Discussion in 'E-mail Discussions' started by AlaskanWolf, Jul 9, 2002.

  1. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    Alot of my customers (well sporaticly) are starting to open a bunch of these tickets, all bascially the same error which is

    550 Host (theirdomain.com) [users-ip] is not permitted to relay through server.domain.com.

    Many of my customers confirm they have the &login to smtp& checkmarked in their programs yet still get such error

    any suggestions?
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Is there more to the error?
    What's in exim_mainlog ?

    This might have something to do with reverse dns which exim is being increasingly anal about lately. If people attempting to relay through don't have valid reverse dns it eats the message and sez they aren't permitted.

    Your server's exim mainlog (and perhaps rejectlog?) should have more detail to help pinpoint this.
     
  3. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    i think these are the correct entries

    2002-07-07 13:49:41 refused relay (host) to &amistad@tut.by& from &lisr@leaderschool.org& H=(leaderschool.org) [194.158.202.162] (failed to find host name from IP address)
    2002-07-07 13:49:46 refused relay (host) to &jamesone@mail.ru& from &lisr@leaderschool.org& H=(leaderschool.org) [194.158.202.162] (failed to find host name from IP address)
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Yea, it's all related to reverse dns.
    Lovely.
    Some ISPs don't set that up for their dialup/dsl users, which is pretty poor.

    I think you can turn off that requirement in your /etc/exim.conf , do a search for &reverse& and &lookups& within the file.
    It's at your own risk though.
     
  5. hst

    hst Well-Known Member

    Joined:
    Feb 24, 2002
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    I've had this a lot

    ISPs have began blocking any outgoing mail that doen't originate from there mailservers to try and cope with SPAM. Earthlink did it recently.

    The fix is fairly simple. If your clients will go to the settings in there email client and change the outgoing SMTP server only and click on the button that says &my server requires authentication& it will work everytime. Sometimes just checking the &my server requires authentication& will do it on its own.

    Just as a note, it's not a problem at all on your systems, its the clients ISP thats kicking back the message and blocking the mail. I lost a few clients figuring this out because they thought it was our problem until the switched host and had the same issue.
     
  6. Starhawk-cyberpixels

    Joined:
    Jan 1, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    What about the same problem with incoming?

    I'm actually experiencing the same error message, but with inbound mail. i.e. mail accounts on the affected server are bouncing back all incoming messages with that same &no relaying allowed& error message.

    I already thought that reverse DNS lookup was the issue and I commented out the &host_lookup& line in exim.conf. That didn't solve the problem unfortunately.

    The only other thing I can think of that might be broken is the line:


    host_accept_relay = +allow_address : lsearch;/etc/relayhosts : localhost

    But I'm not really comfortable messing with that....

    Input?
     
  7. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    look if you ips are listed on http://www.spews.org ?
     
  8. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Have the ones with problems first &check& their eMail before sending. Even with SMTP verification it sometimes doesn't work with Cpanel/Exim.
     
  9. Annette

    Annette Well-Known Member
    PartnerNOC

    Joined:
    Aug 12, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    16
    I believe the item that controls this is host_lookup. Generally, it's set to do lookups on all inbound IP requests:

    host_lookup = 0.0.0.0/0

    You could try commenting that out and restarting exim to see if that does the trick. The unable to find hostname from IP is getting to be more of a pain, especially from people trying to send from private networks where there is no PTR set for individual client machines.
     
Loading...

Share This Page