The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RELEASE pending

Discussion in 'General Discussion' started by cPanelNick, Nov 3, 2004.

  1. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This thread serves to house any problems introduced into EDGE/CURRENT since the last RELEASE build, as well as critical issue that remain unfixed. Please post them here.
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
  3. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    Always set the sender when calling sendmail from a shell.. this is a better solution.
     
  5. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    Yea, but many pre-written scripts, such as bulletin board, etc, do not do this, so bounces come back to that admin of the server rather than the admin address of the bulletin board software. I understand that what you are suggesting is best practice, but I don't understand why a configuration, that was safety net for this issue, should be removed from the exim.conf file when it works. Maybe I am missing something.
     
  6. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    Cpanel keeps messing up our proftpd.conf settings which is creating problems for our login monitoring scripts and admins

    Please see http://bugzilla.cpanel.net/show_bug.cgi?id=1527

    Although not 'critical' it was introduced very recently and it is causing us problems. Would very much appreciate if you could do something about this
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    I think having the ability to set the sender rather then just assuming the sender if the from address is better. If you disagree, you can use the advanced exim configuration editor to change the behavior.

    Add this to the top box

    local_from_check = false
    untrusted_set_sender = root


    Then after the being rewrite. Add the two rewrites in the box.

    And it will be maintained between updates.
     
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Fixed in the next EDGE
     
  9. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
  10. cPanelBilly

    cPanelBilly Guest

    From the autoresponder page:
     
  11. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Being discarded would be fine. What is happening now is that an NDR is sent to the original sender in addition to the actions of the autoresponder.

    [EDIT]The original forum thread discussing the issue can be found here. That thread may give you a better idea what I am talking about if you still do not grasp the problem [/EDIT]
     
    #11 SarcNBit, Nov 3, 2004
    Last edited: Nov 3, 2004
  12. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    Nick, you are correct. But we are web hosts with clients running all sorts of scripts which don't necessarily follow best practices. Thanks for the fix. :)
     
  13. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    18
    That was the point I was trying to make. You made it better than I. And yes, I do appreciate the fix.
     
  14. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
  15. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Turning off eximstats in the service manager NEVER turns it off.
     
  16. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
  17. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    untick Exim Stats Daemon in Tweak Settings as well.
     
  18. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Forgot to mention we done that aswell. I think chkservd restarts it automatically or something
     
  19. cPanelBilly

    cPanelBilly Guest

    ok I can see how that is worded badly. Basically the autoresponder passes it on to the next handler for that address which in your case is:
    *: :fail:

    Thus the failed message. The fix is to create a forwarder that goes to :blackhole:
     
  20. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Please read post number 6 in the forum thread discussing the issue.
     
Loading...

Share This Page