The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Remote mysql connectivity issue

Discussion in 'Database Discussions' started by weblinks, Oct 14, 2016.

  1. weblinks

    weblinks Member

    Joined:
    Sep 19, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Pakistan
    cPanel Access Level:
    Root Administrator
    my clients are facing problem in remote mysql connectivity, they define there ip in remote database access hosts in cpanel, but still not able to connect. I am using csf firewall and i enabled port 3306 in it. I test myself but failed to connect remotely

    using software it gives
    2003 can't connect to mysql server '137.74.173.xxx' (10038)

    and if telnet server

    Connecting To 137.74.173.xxx...Could not open connection to the host, on port 3306: Connect failed

    I restarted csf / mysql service but my issue don't resolve pls help
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    The error output you provided suggests port 3306 isn't open. Could you let us know what steps you took in your CSF configuration to allow access over port 3306? Did you add an entry in the /etc/csf/csf.allow file? Also, what's the content of your /etc/my.cnf file?

    Thank you.
     
  3. weblinks

    weblinks Member

    Joined:
    Sep 19, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Pakistan
    cPanel Access Level:
    Root Administrator
    In CSF

    1. Could you let us know what steps you took in your CSF configuration to allow access over port 3306?

    I define into firewall configuration -> IPv4 Port Settings - > Allow incoming TCP ports -> TCP_IN = 3306

    2. Did you add an entry in the /etc/csf/csf.allow file?

    what ip ?
    I put my static ip and test again not working same error

    3. what's the content of your /etc/my.cnf file?

    [mysqld]
    default-storage-engine=MyISAM
    innodb_file_per_table=1
    performance-schema=0
    bind-address=127.0.0.1
    max_allowed_packet=268435456
    open_files_limit=35000
     
  4. weblinks

    weblinks Member

    Joined:
    Sep 19, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Pakistan
    cPanel Access Level:
    Root Administrator
    ok, thanks my issue resolved. by comment out that line

    #bind-address=127.0.0.1
     
    cPanelMichael likes this.
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page