Remote server can't resolve email sender domain

Malagana

Member
Apr 27, 2012
10
0
51
cPanel Access Level
Root Administrator
Hi, a couple days ago I updated my server to WHM v74.0.9 but right now some accounts with dedicated IP address are having issues sending and receiving email from and to certains domains. The weird thing is that If we sent email from one host account ussing the main server ip address to those domains the emails are delivered OK

The exim message is the following:

Code:
SMTP error from remote mail server after pipelined MAIL FROM:<[email protected]> SIZE=124910: 451 4.1.8 Domain of sender address [EMAIL][email protected][/EMAIL] does not resolve
And also for the domain where we are sending our email

retry time not reached for any host for 'to-client-domain.com'

The sender from one of the domains with this issue get this message:
451 xxxx.com Name server timeout

  • Our domain is resolving OK
  • We have checked PTR records and are OK
  • We dont have any firewall issues
Any Ideas?
 
Last edited by a moderator:

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter

Malagana

Member
Apr 27, 2012
10
0
51
cPanel Access Level
Root Administrator
Hi,

The setting “Send mail from the account’s IP address” is enabled, each acccount that has a dedicated IP address has is PTR record OK so the sending domains resolve to the dedicated IP.

I don’t know if this is a DNS issue or where to look to know what is happening here. Since the remote server can’t find or resolve the email senders domain on our server

I didn’t do anything else besides the update to WHM.
 

Malagana

Member
Apr 27, 2012
10
0
51
cPanel Access Level
Root Administrator
@cPanelLauren yes we have some content in the /etc/mailhelo and /etc/mailips file but the next two options are off right now


Reference /etc/mailhelo for outgoing SMTP HELO
Reference /etc/mailips for outgoing SMTP connections
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,254
313
Houston
Hi @Malagana


Does the issue persist if you remove the data from
Code:
/etc/mailhelo
(regardless of whether or not you have the setting to reference it enabled)

Also, can you run a successful traceroute to the IP addresses in question?
 

Malagana

Member
Apr 27, 2012
10
0
51
cPanel Access Level
Root Administrator
Hi @Malagana


Does the issue persist if you remove the data from
Code:
/etc/mailhelo
(regardless of whether or not you have the setting to reference it enabled)

Also, can you run a successful traceroute to the IP addresses in question?
Hi, Lauren


Right now the domain is using the info on /etc/mailhelo and /etc/mailips using the server IP instead the dedicated for sending emails, with the sames results. Below are the response from the remote mail server when I tested from Telnet:

Code:
telnet INBOUND.pok.com.mx.NETSOLMAIL.NET 25

HEK220 inbound.net.registeredsite.com ESMTP SMTP Service (NO SPAM/UCE)                                                                               
helo c2e-us.net
250 atl4mhib41.myregisteredsite.com Hello chrome.cliccreativelabs.com [142.44.136.138] (may be forged), pleased to meet you
mail from: [email protected]
451 4.1.8 Domain of sender address [email protected] does not resolve
Connection closed by foreign host.
Regarding to the accounts with dedicated IP we can send mails without problems to others domain, the webs are resolving OK and also I can traceroute to the dedicated IP without problems from other machines.

I'm going to try deleting the content inside /etc/mailhelo but until now nothing seems to work.

I do'nt know if is something that we can't fix from our side.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,254
313
Houston
I'm going to try deleting the content inside /etc/mailhelo but until now nothing seems to work.
Let me know how it goes removing the information there - if this doesn't work can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

Malagana

Member
Apr 27, 2012
10
0
51
cPanel Access Level
Root Administrator
Let me know how it goes removing the information there - if this doesn't work can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
Hi, Lauren

The support request ID is
10623945