remoteMYSQL access issues

medalto

Registered
Feb 9, 2020
1
0
1
uk
cPanel Access Level
Website Owner
I want to download ( for local use ) my DB from my host using mysqldump
eg
mysqldump --user=xxxx -p --host=myhostingco.com -A -v >/tmp/DB.sql

It works with my xx.xx.xx.xx IP entered in the server remoteMySQL config , but not with the FQDN I have that points to my machine.

My hosting support point me to your documentation that says it should work with FQDN . but mysqldump from my local machine isnt allowed access with the FQDN added to the remoteMYSQL config and the xx.xx.xx.xx removed.

Is it
- the documentation
-me
-the hosting setup

that is getting this wrong ?
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,753
311
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Your hosting provider may have skip-name-resolve enabled, plus I think the mysql treats [email protected] different than [email protected] You could try putting your host name in the rmeote access field, but I am not sure offhand if that takes domains names.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,261
313
Houston
You can add a hostname rather than an IP:
Host (% wildcard is allowed)

And it's noted in the documentation: Remote MySQL | cPanel & WHM Documentation

When you create a user through the cPanel interface, it creates the following automatically

Code:
MariaDB [(none)]> select host, user from mysql.user where user like 'imauser%';
+-------------------------+---------+
| host                    | user    |
+-------------------------+---------+
| <MYIPADDRESS>          | imauser |
| remoteserver.com             | imauser |
| localhost               | imauser |
| server.anotherremoteserver.tld | imauser |
+-------------------------+--
But with that being said, it sounds a LOT like your provider may have skip-name-resolve enabled in their my.cnf file as @GOT suggested.