Remove option to forward emails to improve IP reputation?

pueblosnet

Active Member
Dec 23, 2003
38
0
156
Recently I have been advised from cPanel support, that to improve the reputation of my IP, do not allow email redirections from accounts hosted to external services such as gmail or hotmail. So, after notifying clients, I'm deleting them.

I understand that this is necessary for the technical part: the re-sending of spam, SPF, etc. but at a commercial and practical level it is a big problem because the clients will have to do something about it, either configure gmail in another way or start using the contracted email.

I wanted to consult the forum if someone else has been in this situation, is this the right way? Is there any option that is escaping me? Thank you.
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,739
301
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
What we recommend is a combination of a good inbound filter and a good outbound filter. The inbound filter will block more incoming spam than just SpamAssassin and the outbound filter would block even more, plus it shields your IPs from being blocked.

There are a lot of options out there, but we normally suggest MagicSpam for inbound and MailChannels for outbound.
 

LucasRolff

Well-Known Member
Community Guide Contributor
May 27, 2013
141
84
78
cPanel Access Level
Root Administrator
I block forwarders because it's a pain.

What @GOT mentions about using MagicSpam or MailChannels - keep in mind that sending via MailChannels will actually follow the RFC and not forward email if it breaks the SPF records by the original sender.

You can then use SRS to prevent this, but - really, if people need to forward emails to an external account, then they should probably just host their email externally in first place.

Either you allow forwarders and accept that your deliverability at times can be bad, or you do not offer forwarders.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello @pueblosnet,

Have you already tried forcing SpamAssassin on globally and then enabling the below option via WHM >> Exim Configuration Manager >> Basic Editor >> Apache SpamAssassin Options?

Do not forward mail to external recipients based on the defined Apache SpamAssassin™ score (Minimum: 0.1; Maximum: 99.9)

You could set the score to be more aggressive than the default SpamAssassin score used for inbound scanning.

Thank you.