Remove the new ModSecurity™ Tools from WHM

deka

Member
Jul 24, 2014
17
0
1
cPanel Access Level
Root Administrator
The new intergration of ModSecurity looks great, but I see that it is possible for each account to disable ModSecurity.
Is it possible to disable this option in cPanel in WHM, so ModSecurity is not visible in cPanel.
I'd assume you could here:
Home » Packages » Feature Manager

I'd like to remove the whole new modsecurity feature from WHM if possible. I do not want ModSecurity™ Tools nor ModSecurity™ Configuration in WHM.

I use the ConfigServer ModSecurity Control plugin to manage and all I can see happening is the new WHM/cPanel ModSecurity integration creating conflicts in the setup I already use.
 

deka

Member
Jul 24, 2014
17
0
1
cPanel Access Level
Root Administrator
Re: New ModSecurity

Is it possible to remove the ModSecurity™ Tools and revert back to the display that used to be in the plugin?

The new set up reqiures you to click a link to see the target URL and to see the rule broken also requires a click - and worse, you're now presented with editable options that are labbelled critical. And do what exactly?

Previously, all this data was easily viewable holistically in plugin without the need to click links, and rulesets updated easily in modsec2.user.conf - To me, the new setup has succeeded in complicating things unnecessarily.
 

Infopro

Well-Known Member
May 20, 2003
17,090
516
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
I've moved your comments to a new thread here.

Documentation for this new Feature can be found here:
ModSecurity Tools - cPanel Documentation

There is no way to remove or disable it that I'm aware of. There is this Feature Request that you might like to know about, and comment on here:

mod_sec rules - cPanel Feature Requests

An official comment has been posted there:

...
Again, the intention here is to deliver this for cPanel & WHM 11.48.

I also encourage everyone to take a look a the revamped ModSecurity UI for cPanel & WHM 11.46 once it his the EDGE tier. That revamp was the first stage in this process of improving ModSecurity within cPanel & WHM. Feedback regarding the 11.46 ModSecurity UI revamp will assist in shaping this feature request.