Status
Not open for further replies.

Jeff75

Well-Known Member
Apr 11, 2003
555
0
166
For some reason public_ftp keeps being added whenever a create a new account. I am not going to offer anonymous FTP and I do not want this directory to be added to their account.

I tried disabling public_ftp in the latest 7.x STABLE version of WHM for FreeBSD and it keeps showing enabled. Can somebody tell me what I need to do to keep this directory from being created? I looked in /root/cpanel3-skel but it wasn't in there.

cPanel.net Support Ticket Number:
 

trakwebster

Well-Known Member
Jan 29, 2003
143
0
166
Do you need to offer ftp to *anyone*, or are you limiting file transfers to scp and ssh?

If you're offerring no ftp, then you can disable the ftp server. However, cpanel has a daemon called something like chkservd whose purpose in life is to make sure that apache, bind, ftp, and similar things are running. This rascal chkservd will start up ftp even after you've killed it. Alternately, if you *really* kill ftp then chkservd will send you an email every five minutes to complain.

However, the process of HOWTO successfully deactivate ftp is documented if you want to take this route. Info is here: . http://forums.cpanel.net/showthread.php?s=&threadid=11551
 
Last edited:

Jeff75

Well-Known Member
Apr 11, 2003
555
0
166
I'm offering FTP to everyone, however I'm not going to offer anonymous FTP to anybody. For some reason the public_ftp directory is created everytime I create an account so I have to go in and delete it everytime which is taking a lot of extra time.

cPanel.net Support Ticket Number:
 

MySundown

Well-Known Member
Jun 2, 2003
125
0
166
Delete the directory from your cpanel skeleton directory (/root/cpanel3-skel on my server). It shouldn't be created on new accounts.

However, the users could always manually create a public_ftp directory in their home directory.

But, it's a precaution at least.

You can do locate public_ftp every so often to see if any of your clients have created it.

cPanel.net Support Ticket Number:
 

Jeff75

Well-Known Member
Apr 11, 2003
555
0
166
The strange thing is, is that there is no directory in /root/cpanel3-skel/ named public_ftp. I cannot figure out where this directory is being created from in the new account set up process. I keep trying to disable Anonymous FTP under Tweak FTP settings, but it keeps showing "enabled".

I tried running locate public_ftp but nothing came up. There's over a hundred of these directories in each client's home directory. Does anybody know how I can delete them all from each user's directory without having to manually delete each one?

cPanel.net Support Ticket Number:
 

Matt-AWD

Member
Jun 17, 2003
9
0
151
Are you giving each user their own IP? If not, anonymous FTP won't work on their account anyway.

cPanel.net Support Ticket Number:
 

Jeff75

Well-Known Member
Apr 11, 2003
555
0
166
Yes, each user is assigned their own IP address.

cPanel.net Support Ticket Number:
 

MySundown

Well-Known Member
Jun 2, 2003
125
0
166
Originally posted by Matt-AWD
Are you giving each user their own IP? If not, anonymous FTP won't work on their account anyway.

cPanel.net Support Ticket Number:
Not true. It used to be like that, but now users with shared ips can have anonymous ftp too. Try going to ftp://ftp.mysundown.net/ . It's ip (216.67.237.152) has 100+ other accounts on it.

cPanel.net Support Ticket Number:
 

tmunk

Member
Apr 4, 2004
18
2
153
Arizona
Jeff75 said:
For some reason public_ftp keeps being added whenever a create a new account. I am not going to offer anonymous FTP and I do not want this directory to be added to their account.

I tried disabling public_ftp in the latest 7.x STABLE version of WHM for FreeBSD and it keeps showing enabled. Can somebody tell me what I need to do to keep this directory from being created? I looked in /root/cpanel3-skel but it wasn't in there.
I am having this exact same problem. I try to disable anonymous ftp in the WHM Main >> Service Configuration >> FTP Configuration screen and I get this error, and anonymous ftp is still enabled:
################################################
Disabling Anonymous Ftp [an error occurred while processing this directive]
Complete!! Updating ftp passwords for all users Ftp password files updated. Ftp vhost passwords synced
Attempting to restart ftpserver
Waiting for ftpserver to restart.... . . . . . . . . . . finished.
ftpserver status
root 28537 0.0 0.2 2600 1708 ?? Ss 12:12PM 0:00.04 pure-ftpd (SERVER) (pure-ftpd)
ftpserver started ok
################################################

has anyone come up with a fix for this? I've tried setting up an /etc/ftpuser file as suggested in another thread, and I have no /etc/pureftpd.conf file to edit as another thread suggested, so I'm at a loss.

I'm using WHM 10.8.0 cPanel 10.8.1-R113
FreeBSD 4.9-RELEASE i386 - WHM X v3.1.0

Help? :eek:
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
Please do not dig up 3 year old threads like this. If you still need an answer, start a new thread if there isn't a recent one.
 
Status
Not open for further replies.