Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Removing suexec

Discussion in 'General Discussion' started by dennismv, Sep 23, 2007.

  1. dennismv

    dennismv Member

    Joined:
    Sep 8, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    151
    I have apache+php suexec

    I tried to edit httpd.conf file to remove User directives in VirtualHosts and to uncomment mod_php module so that it works.

    When I restarted I got an error that I could not access /etc (by session_start() to create sessions).

    I tried chmod 777 /etc, and disabling SuExec through WHM, and it didn't help.

    What could be wrong ?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Looks like you're confusing phpsuexec and suexec which are different modules. If you want to disable phpsuexec you should restore your httpd.conf to how it was before and then run easyapache and rebuild apache+php after disabling the phpsuexec option.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice