The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rename htaccess.file

Discussion in 'General Discussion' started by chocolatecake, Jan 26, 2011.

  1. chocolatecake

    chocolatecake Registered

    Joined:
    Jan 26, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I am pretty much a newbie and struggling with a Joomla site and SEF URL's.
    To get the apache rewrite to work, apparently I need to change the name of the htaccess.txt file to .htaccess.
    I did this thru cPanel, by clicking on the file and choosing rename.
    But a file is still there named as the original htaccess.txt... so I tried to rename it again and it said there was already a file with this name... but I cannot see it.
    And in my Joomla SEF extension, it now tells me there is a problem with my .htaccess file.
    Am I not actually able to rename this file thru cPanel? And if not, how do I go about it please?
     
  2. LinuxTechie

    LinuxTechie Well-Known Member

    Joined:
    Jan 22, 2011
    Messages:
    502
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hello,

    It seems your .htaccess is hidden which is the reason why you are not able to see the file.

    When you click on the File Manager icon, do you get a prompt to show hidden files? If not, scroll down to the bottom of the page you see when you first login to the cPanel interface and click on reset all interface settings. Refresh the page and when you click on the File Manager icon, in the popup that appears, check the option to display hidden files.

    The htaccess.txt won't create any issue. If you don't want it you can remove it after finding your .htaccess hidden file.
     
  3. toplisek

    toplisek Active Member

    Joined:
    Jan 7, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Which SEF you are using actually?
     
Loading...

Share This Page