Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Required Perl module SQL::Statement not present. Aborting catalog. In line 8 of the c

Discussion in 'Database Discussion' started by aress, May 8, 2005.

  1. aress

    aress Active Member

    Joined:
    May 5, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    156
    Hello All,

    I have a Cpanel server and when I try to upcp i.e /scripts/upcp --force
    FYI: service cpanel restart also generates the same error.

    I get the following error :
    The previous Interchange server was not running and probably
    terminated with an error.
    Low traffic settings.
    Calling UI......UI is loaded...
    Interchange V4.8.6
    Configuring catalog drissvir...Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    drissvir config error: Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    drissvir: error in configuration. Skipping.
    drissvir: config error. Skipping.
    Configuring catalog incomepl...Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    incomepl config error: Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    incomepl: error in configuration. Skipping.
    incomepl: config error. Skipping.
    Configuring catalog jwhite...Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    jwhite config error: Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    jwhite: error in configuration. Skipping.
    jwhite: config error. Skipping.
    Configuring catalog livesem...Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    livesem config error: Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    livesem: error in configuration. Skipping.
    livesem: config error. Skipping.
    Configuring catalog pioussa...Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    pioussa config error: Required Perl module SQL::Statement not present. Aborting catalog.
    In line 8 of the configuration file 'catalog.cfg':
    Require module SQL::Statement

    pioussa: error in configuration. Skipping.
    pioussa: config error. Skipping.



    Tried UPCP , and service cpanel restart
    .. /scripts/checkinterchange
    .. /scripts/fixinterchange
    .. /scripts/fixinterchangeperm
    .. /scripts/rebuildinterchangecfg

    even
    /scripts/fixcartwithsuexec drissvir
    /scripts/fixcartwithsuexec incomepl
    /scripts/fixcartwithsuexec jwhite
    /scripts/fixcartwithsuexec pioussa

    also tried rebooting the server but no use :((.

    I have the following version running on my server .
    Interchange V4.8.6
    perl version v5.8.3

    Please help me out. Do any one have an idea what to do to fix this :(( .

    Regards,
    Sonual Shinde. :(

    Waiting anxiously



    Following is the Code in the Line 8 of the CATALOG.CFG
    # catalog.cfg
    # See the 'icconfig' document for details.

    #==========================================================================#

    # Read in initial variables from a database.

    VariableDatabase variable

    #==========================================================================#

    # Allow a template to drop in some beginning config.
    include etc/before.cfg

    #==========================================================================#

    # Warn if any important modules or usertags are missing.

    Require module Digest::MD5 "Need %s %s for better cache keys."
    Require module Safe::Hole
    Require module SQL::Statement
    Require module LWP::Simple

    Require UserTag email email_raw var loc table_editor button
     
    #1 aress, May 8, 2005
    Last edited: May 8, 2005
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Have you tried running:

    /scripts/perlinstaller --force SQL::Statement
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. aress

    aress Active Member

    Joined:
    May 5, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    156
    Hi Jonathan,

    I did execute that cmd /scripts/perlinstaller --force SQL::Statement. went all well. But still having the same error :(

    BTW Thanks for your reply.

    Please anymore suggestion.

    Regards,
    Sonaul Shinde

    __________________
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I'd suggest logging a Support Ticket with cPanel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. aress

    aress Active Member

    Joined:
    May 5, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    156
  6. aress

    aress Active Member

    Joined:
    May 5, 2004
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    156
    Hello There,
    GUESS WHAT I HAVE A SOLUTION FOR THIS :
    I Logged in the WHM and
    under "Service Configuration" I have option"Enable/Disable SuExec"
    What I did was I disabled it :).

    And then restarted the interchange. Well everything is sorted :)

    RELIEF ATLAST:))


    Thanks To All who tried to help me :)
    Thanx to you JOHN :))
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice