Reseller account not showing owned accounts in "Current User" menu?

Benjamin D.

Well-Known Member
Jan 28, 2016
133
19
68
Canada
cPanel Access Level
Root Administrator
Hi, I've created a reseller account earlier today and now that reseller just created his first account inside his WHM, but upon logging in his cPanel account (which is a reseller one) he only sees his own account listed under the "Current User" dropdown menu in the top right.

Here's everything we tried so far:

- Log out and log back in.
- Using the root WHM, refresh (modify) the missing account.
- Using the root WHM, refresh (modify) the missing account DNS zones.
- Using the root WHM, change the missing account's plan.
- Change his reseller cPanel account language and theme.

The missing account is well owned by the reseller account and it can also be accessed by directly logging in cPanel with their password, but isn't showing in the reseller's cPanel "Current User" dropdown menu for fast access.

Any clue as to what to do to make it show there?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello,

Please access WHM as "root" and verify what's configured for the following option under the "System" tab in "WHM >> Tweak Settings":

Accounts that can access a cPanel user account:

Thank you.
 
  • Like
Reactions: Benjamin D.

Benjamin D.

Well-Known Member
Jan 28, 2016
133
19
68
Canada
cPanel Access Level
Root Administrator
YOU SIR... diserve to win a handful of internets. More seriously, I don't recall ever changing this... maybe an update did recently? It was on "cPanel User only" and I had to put it on " Account-Owner and cPanel User Only"

  • Root, Account-Owner, and cPanel User default
  • Account-Owner and cPanel User Only
  • cPanel User Only
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,225
463
Hello,

I'm glad to see that helped. I'm not seeing any recent change to the default selection for this option, as it's still "Root, Account-Owner, and cPanel User" as of cPanel version 66.

Thank you.