The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Resolved] DNS concerns and tilde option

Discussion in 'Bind / DNS / Nameserver Issues' started by tish25, Oct 5, 2012.

  1. tish25

    tish25 Registered

    Joined:
    Oct 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    If I can reach my domain via http://IP/~username, is it safe to assume that my DNS zone records for that domain are correctly set up, though not propagated? I just don't want to wait two days and then find out they are still wrong (been working on it too long already). Wondering if this is a logical test or not.

    Thanks!
     
  2. pwhjenny

    pwhjenny Well-Known Member

    Joined:
    Aug 31, 2012
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    No, you can't assume that. As above meothod uses apache mod_userdir module and the primary IP of the server. But you can use dig command to make sure that the dns records are setup correctly. Let us say your new nameservers are ns1.yourdomain.com. You can run

    To make sure A records.

    dig @ns1.yourdomain.com yourdomain.com A

    To make sure mx record

    dig @ns1.yourdomain.com yourdomain.com mx

    etc
     
  3. tish25

    tish25 Registered

    Joined:
    Oct 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page