The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Resolving Dependencies" problem

Discussion in 'General Discussion' started by Bdzzld, Apr 3, 2006.

  1. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi,

    One of my server is having severe problems "resolving depencies" and therefore the update functionality no longer works. Besides this, everything works fine...

    (part one)
    Code:
    Found hostname to be xxx, which resolves to xx.xx.xx.xxx
    Hostname Virtual Host is already setup
    PHP version file is up to date
    Ftp Quota Check v1.0
    Updating xxx:xxx....Done
    Cpanel updates are coming from layer2.cpanel.net
    MailBox (xxx@xxx) [critical]
    Sent Disk Warning
    MailBox (xxx@xxx) [warn]
    Using smartcheck config 5.32 for smartctl(5.33)
    Checking /dev/sda....S.M.A.R.T does not appear to be enabled for this device.
    Ftp Setup Script Version 6.0
    Fetching version information from http://updates.cpanel.net/ftpinstall/version (STABLE)....Done
    This is the pure-ftpd 1.0.20 installer release number 17.tls for platform centos 4.2
    pure-ftpd is up to date.  Use ftpup --force to force a reinstall
    Exim (maildir) Setup Script Version 20.0
    Fetching version information from http://updates.cpanel.net/eximinstall/version (STABLE)....Done
    This is the exim 4.52 installer release number 15 for platform centos 4.2
    exim is up to date.  Use eximup --force to force a reinstall
    MySQL Setup Script Version 6.1
    Fetching version information from http://updates.cpanel.net/mysqlinstall/version (STABLE)....Done
    This is the MySQL 4.1.13 installer release number 0.glibc23 for platform
    MySQL-4.1.13 is up to date
    /usr/sbin/setfiles:  read 2 specifications
    /usr/sbin/setfiles:  labeling files under /
    /usr/sbin/setfiles:  hash table stats: 0 elements, 0/65536 buckets used, longest chain length 0
    /usr/sbin/setfiles:  Done.
    Install Complete
    bandmin Setup Script Version 1.0
    Fetching version information from http://updates.cpanel.net/bandmininstall/version (STABLE)....Done
    This is the bandmin 1.6.1 installer release number 1 for platform centos 4.2
    bandmin is up to date.  Use bandminup --force to force a reinstall
    checkyum version 20.1
    bandmin is up to date (Thu Jul 28 15:11:28 2005)
    portsentry is up to date (Wed Mar 10 06:21:21 2004)
    Using newyum support...
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package openssl.x86_64 0:0.9.7a-43.8 set to be updated
    ---> Package openssh-server.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    ---> Package openssl-devel.x86_64 0:0.9.7a-43.8 set to be updated
    ---> Package openssl.i686 0:0.9.7a-43.8 set to be updated
    ---> Package gnupg.x86_64 0:1.2.6-3 set to be updated
    ---> Package xorg-x11-libs.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package gcc.x86_64 0:3.4.5-2 set to be updated
    ---> Package xorg-x11-devel.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package openssh.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    ---> Package openssh-clients.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    --> Running transaction check
    --> Processing Dependency: gcc = 3.4.4-2 for package: gcc-objc
    --> Processing Dependency: gcc = 3.4.4-2 for package: gcc-c++
    --> Processing Dependency: audit-libs >= 1.0.12 for package: openssh-server
    --> Processing Dependency: cpp = 3.4.5-2 for package: gcc
    --> Processing Dependency: gcc = 3.4.4-2 for package: gcc-g77
    --> Processing Dependency: gcc = 3.4.4-2 for package: gcc-gnat
    --> Processing Dependency: binutils >= 2.15.92.0.2-18 for package: gcc
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh-clients
    --> Processing Dependency: libgcc >= 3.4.5-2 for package: gcc
    --> Processing Dependency: gcc = 3.4.4 for package: libtool
    --> Processing Dependency: libz.so.1()(64bit) for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh
    --> Processing Dependency: gcc = 3.4.4-2 for package: gcc-java
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh-server
    --> Processing Dependency: libfontconfig.so.1()(64bit) for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1()(64bit) for package: gnupg
    --> Processing Dependency: libz.so.1()(64bit) for package: openssl
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package gcc-java.x86_64 0:3.4.5-2 set to be updated
    ---> Package binutils.x86_64 0:2.15.92.0.2-18 set to be updated
    ---> Package gcc-gnat.x86_64 0:3.4.5-2 set to be updated
    ---> Package libtool.x86_64 0:1.5.6-4.EL4.1.c4.3 set to be updated
    ---> Package fontconfig.x86_64 0:2.2.3-7 set to be updated
    ---> Package gcc-c++.x86_64 0:3.4.5-2 set to be updated
    ---> Package libgcc.x86_64 0:3.4.5-2 set to be updated
    ---> Package cpp.x86_64 0:3.4.5-2 set to be updated
    ---> Package gcc-g77.x86_64 0:3.4.5-2 set to be updated
    ---> Package zlib.x86_64 0:1.2.1.2-1.2 set to be updated
    ---> Package gcc-objc.x86_64 0:3.4.5-2 set to be updated
    ---> Package audit-libs.x86_64 0:1.0.12-1.EL4 set to be updated
    --> Running transaction check
    --> Processing Dependency: zlib = 1.2.2.1-2 for package: zlib-devel
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libgcj >= 3.4.5 for package: gcc-java
    --> Processing Dependency: libtool-libs = 1.5.6-4.EL4.1.c4.3 for package: libtool
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libobjc = 3.4.5-2 for package: gcc-objc
    --> Processing Dependency: libstdc++-devel = 3.4.5 for package: gcc-c++
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libstdc++ = 3.4.5 for package: gcc-c++
    --> Processing Dependency: audit-libs = 1.0.3-6.EL4 for package: audit
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libgcj-devel >= 3.4.5 for package: gcc-java
    --> Processing Dependency: libf2c = 3.4.5-2 for package: gcc-g77
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libgnat = 3.4.5-2 for package: gcc-gnat
    --> Restarting Dependency Resolution with new cError: Missing Dependency: zlib = 1.2.2.1-2 is needed by package zlib-devel
    
     
  2. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    (part two)
    Code:
    Error: Missing Dependency: libz.so.1 is needed by package gd
    Error: Missing Dependency: libz.so.1 is needed by package fontconfig
    Error: Missing Dependency: libz.so.1 is needed by package openssl
    Error: Missing Dependency: libz.so.1 is needed by package libtiff
    Error: Missing Dependency: libz.so.1 is needed by package freetype
    Error: Unable to satisfy dependencies
    Error: Package zlib-devel needs zlib = 1.2.2.1-2, this is not available.
    Error: Package gd needs libz.so.1, this is not available.
    Error: Package xorg-x11-libs needs libz.so.1, this is not available.
    Error: Package freetype needs libz.so.1, this is not available.
    Error: Package fontconfig needs libz.so.1, this is not available.
    Error: Package openssl needs libz.so.1, this is not available.
    Error: Package libtiff needs libz.so.1, this is not available.
    Error: Package libpng needs libz.so.1, this is not available.
    hanges.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package libgcj.x86_64 0:3.4.5-2 set to be updated
    ---> Package libgcj-devel.x86_64 0:3.4.5-2 set to be updated
    ---> Package libobjc.x86_64 0:3.4.5-2 set to be updated
    ---> Package libstdc++-devel.x86_64 0:3.4.5-2 set to be updated
    ---> Package libpng.x86_64 2:1.2.7-1.el4.2 set to be updated
    ---> Package libgnat.x86_64 0:3.4.5-2 set to be updated
    ---> Package audit.x86_64 0:1.0.12-1.EL4 set to be updated
    ---> Package libtool-libs.x86_64 0:1.5.6-4.EL4.1.c4.3 set to be updated
    ---> Package libstdc++.x86_64 0:3.4.5-2 set to be updated
    ---> Package libf2c.x86_64 0:3.4.5-2 set to be updated
    --> Running transaction check
    --> Processing Dependency: zlib = 1.2.2.1-2 for package: zlib-devel
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    --> Processing Dependency: zlib = 1.2.2.1-2 for package: zlib-devel
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    
     
  3. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    (part three)
    Code:
    ---> Package pcmcia-cs.x86_64 0:3.2.7-3.5 set to be updated
    ---> Package glibc-headers.x86_64 0:2.3.4-2.19 set to be updated
    ---> Package util-linux.x86_64 0:2.12a-16.EL4.16 set to be updated
    ---> Package samba-common.x86_64 0:3.0.10-1.4E.6 set to be updated
    ---> Package libuser.x86_64 0:0.52.5-1.el4.1 set to be updated
    ---> Package libgcj4.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package libgfortran.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package autofs.x86_64 1:4.1.3-169 set to be updated
    ---> Package libpng.x86_64 2:1.2.7-1.el4.2 set to be updated
    ---> Package pam-devel.i386 0:0.77-66.14 set to be updated
    ---> Package rpm-python.x86_64 0:4.3.3-13_nonptl set to be updated
    ---> Package libgnat.x86_64 0:3.4.5-2 set to be updated
    ---> Package gcc-c++.x86_64 0:3.4.5-2 set to be updated
    ---> Package libgcj-devel.x86_64 0:3.4.5-2 set to be updated
    ---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package krb5-devel.x86_64 0:1.3.4-27 set to be updated
    ---> Package system-config-network.noarch 0:1.3.22.0.EL.4.2-1 set to be updated
    ---> Package tar.x86_64 0:1.14-9.RHEL4 set to be updated
    ---> Package rpm.x86_64 0:4.3.3-13_nonptl set to be updated
    ---> Package glibc.x86_64 0:2.3.4-2.19 set to be updated
    ---> Package bzip2-libs.x86_64 0:1.0.2-13.EL4.3 set to be updated
    ---> Package krb5-libs.i386 0:1.3.4-27 set to be updated
    ---> Package gcc-objc.x86_64 0:3.4.5-2 set to be updated
    ---> Package policycoreutils.x86_64 0:1.18.1-4.9 set to be updated
    ---> Package shadow-utils.x86_64 2:4.0.3-60.RHEL4 set to be updated
    ---> Package xorg-x11-font-utils.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package glibc-devel.i386 0:2.3.4-2.19 set to be updated
    ---> Package ImageMagick.x86_64 0:6.0.7.1-14.c4 set to be updated
    ---> Package xorg-x11-Mesa-libGL.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package bzip2-devel.x86_64 0:1.0.2-13.EL4.3 set to be updated
    ---> Package libpng.i386 2:1.2.7-1.el4.2 set to be updated
    ---> Package newt.x86_64 0:0.51.6-7.rhel4 set to be updated
    ---> Package binutils.x86_64 0:2.15.92.0.2-18 set to be updated
    ---> Package libobjc.x86_64 0:3.4.5-2 set to be updated
    ---> Package gcc-gnat.x86_64 0:3.4.5-2 set to be updated
    ---> Package pam-devel.x86_64 0:0.77-66.14 set to be updated
    ---> Package system-config-network-tui.noarch 0:1.3.22.0.EL.4.2-1 set to be updated
    ---> Package dhcpv6_client.x86_64 0:0.10-14_EL4 set to be updated
    ---> Package libtool.x86_64 0:1.5.6-4.EL4.1.c4.3 set to be updated
    ---> Package krb5-libs.x86_64 0:1.3.4-27 set to be updated
    ---> Package glibc-devel.x86_64 0:2.3.4-2.19 set to be updated
    ---> Package redhat-logos.noarch 0:1.1.26-1.centos4.1 set to be updated
    ---> Package procps.x86_64 0:3.2.3-8.3 set to be updated
    ---> Package centos-release.x86_64 6:4-3.2 set to be updated
    ---> Package udev.x86_64 0:039-10.12.EL4 set to be updated
    ---> Package netdump.x86_64 0:0.7.14-4 set to be updated
    ---> Package libgcc.x86_64 0:3.4.5-2 set to be updated
    ---> Package xorg-x11-xauth.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package openssl-devel.x86_64 0:0.9.7a-43.8 set to be updated
    ---> Package pam.x86_64 0:0.77-66.14 set to be updated
    ---> Package libtool-libs.x86_64 0:1.5.6-4.EL4.1.c4.3 set to be updated
    ---> Package gcc4-c++.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package tzdata.noarch 0:2006a-1.EL4 set to be updated
    ---> Package hal.x86_64 0:0.4.2-3.EL4 set to be updated
    ---> Package libstdc++.x86_64 0:3.4.5-2 set to be updated
    ---> Package crash.x86_64 0:4.0-2.15 set to be updated
    ---> Package gnupg.x86_64 0:1.2.6-3 set to be updated
    ---> Package numactl.x86_64 0:0.6.4-1.25 set to be updated
    ---> Package xorg-x11-devel.i386 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package libgcj4-devel.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package libf2c.x86_64 0:3.4.5-2 set to be updated
    ---> Package openssl.x86_64 0:0.9.7a-43.8 set to be updated
    ---> Package initscripts.x86_64 0:7.93.24.EL-1.1.centos4 set to be updated
    ---> Package gcc-java.x86_64 0:3.4.5-2 set to be updated
    ---> Package libgcj.x86_64 0:3.4.5-2 set to be updated
    ---> Package glibc.i686 0:2.3.4-2.19 set to be updated
    ---> Package lvm2.x86_64 0:2.02.01-1.3.RHEL4 set to be updated
    ---> Package gcc.x86_64 0:3.4.5-2 set to be updated
    ---> Package rhnlib.noarch 0:1.8.2-1.p23.1 set to be updated
    ---> Package mdadm.x86_64 0:1.6.0-3 set to be updated
    ---> Package selinux-policy-targeted.noarch 0:1.17.30-2.126 set to be updated
    ---> Package libgcc.i386 0:3.4.5-2 set to be updated
    ---> Package up2date.x86_64 0:4.4.67-4.centos4 set to be updated
    ---> Package iputils.x86_64 0:20020927-18.EL4.2 set to be updated
    ---> Package krb5-workstation.x86_64 0:1.3.4-27 set to be updated
    ---> Package python.x86_64 0:2.3.4-14.2 set to be updated
    ---> Package nscd.x86_64 0:2.3.4-2.19 set to be updated
    ---> Package xorg-x11-devel.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package openssh-clients.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    ---> Package samba.x86_64 0:3.0.10-1.4E.6 set to be updated
    ---> Package chkconfig.x86_64 0:1.3.13.3-2 set to be updated
    ---> Package module-init-tools.x86_64 0:3.1-0.pre5.3.2 set to be updated
    ---> Package device-mapper.x86_64 0:1.02.02-3.0.RHEL4 set to be updated
    ---> Package libpng-devel.x86_64 2:1.2.7-1.el4.2 set to be updated
    ---> Package audit-libs.x86_64 0:1.0.12-1.EL4 set to be updated
    ---> Package MAKEDEV.x86_64 0:3.15.2-3 set to be updated
    ---> Package ntsysv.x86_64 0:1.3.13.3-2 set to be updated
    ---> Package libstdc++-devel.i386 0:3.4.5-2 set to be updated
    ---> Package system-config-lvm.noarch 0:1.0.16-1.0 set to be updated
    ---> Package e2fsprogs-devel.x86_64 0:1.35-12.3.EL4 set to be updated
    ---> Package diskdumputils.x86_64 0:1.2.8-2 set to be updated
    ---> Package rpm-libs.x86_64 0:4.3.3-13_nonptl set to be updated
    ---> Package libstdc++.i386 0:3.4.5-2 set to be updated
    ---> Package ypbind.x86_64 3:1.17.2-8 set to be updated
    ---> Package apr.x86_64 0:0.9.4-24.5.c4.1 set to be updated
    ---> Package openssl.i686 0:0.9.7a-43.8 set to be updated
    ---> Package hwdata.noarch 0:0.146.18.EL-1 set to be updated
    ---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package xorg-x11-libs.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package audit.x86_64 0:1.0.12-1.EL4 set to be updated
    ---> Package cpp.x86_64 0:3.4.5-2 set to be updated
    ---> Package psacct.x86_64 0:6.3.2-38.rhel4 set to be updated
    ---> Package file.x86_64 0:4.10-2.EL4.3 set to be updated
    ---> Package centos-yumconf.noarch 0:4-4.5 set to be updated
    ---> Package python-devel.x86_64 0:2.3.4-14.2 set to be updated
    ---> Package e2fsprogs.i386 0:1.35-12.3.EL4 set to be updated
    ---> Package gcc-g77.x86_64 0:3.4.5-2 set to be updated
    ---> Package xorg-x11-xfs.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    ---> Package samba-client.x86_64 0:3.0.10-1.4E.6 set to be updated
    ---> Package openssh.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    ---> Package openssh-server.x86_64 0:3.9p1-8.RHEL4.12 set to be updated
    ---> Package glibc-common.x86_64 0:2.3.4-2.19 set to be updated
    ---> Package gcc4.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package dhclient.x86_64 7:3.0.1-54.EL4 set to be updated
    ---> Package e2fsprogs.x86_64 0:1.35-12.3.EL4 set to be updated
    ---> Package gcc4-gfortran.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package gcc4-java.x86_64 0:4.0.2-14.EL4 set to be updated
    ---> Package rpm-build.x86_64 0:4.3.3-13_nonptl set to be updated
    ---> Package popt.x86_64 0:1.9.1-13_nonptl set to be updated
    --> Running transaction check
    
     
  4. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    (part four)
    Code:
    --> Processing Dependency: libz.so.1()(64bit) for package: xorg-x11-xfs
    --> Processing Dependency: libz.so.1()(64bit) for package: python
    --> Processing Dependency: libz.so.1()(64bit) for package: rpm-libs
    --> Processing Dependency: libz.so.1()(64bit) for package: ImageMagick
    --> Processing Dependency: libz.so.1()(64bit) for package: util-linux
    --> Processing Dependency: libz.so.1()(64bit) for package: rpm-python
    --> Processing Dependency: lError: Missing Dependency: zlib = 1.2.2.1-2 is needed by package zlib-devel
    Error: Missing Dependency: libz.so.1 is needed by package gd
    Error: Missing Dependency: libz.so.1 is needed by package xorg-x11-libs
    Error: Missing Dependency: libz.so.1 is needed by package freetype
    Error: Missing Dependency: libz.so.1 is needed by package fontconfig
    Error: Missing Dependency: libz.so.1 is needed by package libpng
    Error: Missing Dependency: libz.so.1 is needed by package openssl
    Error: Missing Dependency: libz.so.1 is needed by package libtiff
    ibz.so.1()(64bit) for package: gcc-java
    --> Processing Dependency: libz.so.1()(64bit) for package: gnupg
    --> Processing Dependency: libz.so.1()(64bit) for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1()(64bit) for package: libgcj
    --> Processing Dependency: libz.so.1()(64bit) for package: rpm
    --> Processing Dependency: libz.so.1()(64bit) for package: diskdumputils
    --> Processing Dependency: libz.so.1()(64bit) for package: libpng
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh-server
    --> Processing Dependency: libz.so.1()(64bit) for package: openssl
    --> Processing Dependency: libz.so.1()(64bit) for package: gcc4-java
    --> Processing Dependency: libz.so.1()(64bit) for package: file
    --> Processing Dependency: libz.so.1()(64bit) for package: crash
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh-clients
    --> Processing Dependency: libz.so.1()(64bit) for package: rpm-build
    --> Processing Dependency: libz.so.1()(64bit) for package: libgcj4
    --> Processing Dependency: libz.so.1()(64bit) for package: xorg-x11-font-utils
    --> Processing Dependency: libfontconfig.so.1()(64bit) for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1()(64bit) for package: openssh
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package zlib.x86_64 0:1.2.1.2-1.2 set to be updated
    ---> Package fontconfig.x86_64 0:2.2.3-7 set to be updated
    --> Running transaction check
    --> Processing Dependency: zlib = 1.2.2.1-2 for package: zlib-devel
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Finished Dependency Resolution
    Method: Perl Expect
    Fetching CPAN timestamp...Done
    Testing connection speed...(this could take a while)..............Done
    Ping:1.531 Testing connection speed to cpan.wanadoo.nl using wget...(1790000 bytes/s)...Done
    Ping:4.279 Testing connection speed to ftp.easynet.nl using wget...(524520 bytes/s)...Done
    Ping:6.493 Testing connection speed to cpan.scarlet.be using wget...Warning: removing bad mirror cpan.scarlet.be from url list
    test failed...Done
    Ping:7.502 Testing connection speed to ftp.belnet.be using wget...(234610 bytes/s)...Done
    Three usable mirrors located
    Mirror Check passed for cpan.wanadoo.nl (/index.html)
    Dropping unknown config variable 'less'
    Dropping unknown config variable 'make_test'
    commit: wrote '/usr/lib/perl5/5.8.7/CPAN/Config.pm'
    CPAN: Storable loaded ok
    Going to read /home/.cpan/Metadata
      Database was generated on Wed, 29 Mar 2006 15:44:03 GMT
    CPAN: File::HomeDir loaded ok
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
      http://cpan.wanadoo.nl/authors/01mailrc.txt.gz
    Going to read /home/.cpan/sources/authors/01mailrc.txt.gz
    Fetching with LWP:
      http://cpan.wanadoo.nl/modules/02packages.details.txt.gz
    Going to read /home/.cpan/sources/modules/02packages.details.txt.gz
      Database was generated on Sun, 02 Apr 2006 16:45:02 GMT
    Fetching with LWP:
      http://cpan.wanadoo.nl/modules/03modlist.data.gz
    Going to read /home/.cpan/sources/modules/03modlist.data.gz
    Going to write /home/.cpan/Metadata
    Digest::SHA is up to date (5.34).
    Module::Signature is up to date (0.53).
    File::Temp is up to date (0.16).
    File::HomeDir is up to date (0.56).
    File::Spec is up to date (3.17).
    Compress::Zlib is up to date (1.41).
    Archive::Tar is up to date (1.29).
    Archive::Zip is up to date (1.16).
    Data::Dumper is up to date (2.121_04).
    Net::Telnet is up to date (3.03).
    Net::Cmd is up to date (2.26).
    Term::ReadKey is up to date (2.30).
    Term::ReadLine::Perl is up to date (1.0208).
    YAML is up to date (0.58).
    Text::Glob is up to date (0.06).
    Module::Build is up to date (0.2612).
    CPAN is up to date (1.87).
    version is up to date (0.59).
    Archive::Tar is up to date (1.29).
    Archive::Zip is up to date (1.16).
    BSD::Resource is up to date (1.24).
    DBI is up to date (1.50).
    Data::ShowTable is up to date (undef).
    Mysql is up to date (1.2401).
    DBD::mysql is up to date (3.0002).
    Digest::MD5 is up to date (2.36).
    MIME::Base64 is up to date (3.07).
    MIME::Lite is up to date (3.01).
    URI::URL is up to date (5.03).
    HTML::Tagset is up to date (3.10).
    MIME::Base64 is up to date (3.07).
    Digest::MD5 is up to date (2.36).
    URI is up to date (1.35).
    Net::FTP is up to date (2.75).
    HTML::Tagset is up to date (3.10).
    HTML::Parser is up to date (3.51).
    HTML::HeadParser is up to date (2.22).
    LWP is up to date (5.805).
    Parse::RecDescent is up to date (1.94).
    OLE::Storage_Lite is up to date (0.14).
    MIME::Base64 is up to date (3.07).
    Digest::MD5 is up to date (2.36).
    URI is up to date (1.35).
    Net::FTP is up to date (2.75).
    HTML::Tagset is up to date (3.10).
    HTML::Parser is up to date (3.51).
    HTML::HeadParser is up to date (2.22).
    LWP is up to date (5.805).
    Term::ReadKey is up to date (2.30).
    Term::ReadLine::Perl is up to date (1.0208).
    Text::Query is up to date (0.07).
    Image::Size is up to date (2.992).
    DBI is up to date (1.50).
    Safe::Hole is up to date (0.10).
    Tie::ShadowHash is up to date (0.07).
    Set::Crontab is up to date (1.00).
    IO::Scalar is up to date (2.110).
    Storable is up to date (2.15).
    Spreadsheet::ParseExcel is up to date (0.2603).
    Spreadsheet::WriteExcel is up to date (2.16).
    MIME::Base64 is up to date (3.07).
    Digest::MD5 is up to date (2.36).
    URI is up to date (1.35).
    Net::FTP is up to date (2.75).
    HTML::Tagset is up to date (3.10).
    HTML::Parser is up to date (3.51).
    HTML::HeadParser is up to date (2.22).
    LWP is up to date (5.805).
    Business::OnlinePayment::AuthorizeNet is up to date (3.15).
    Business::UPS is up to date (1.13).
    CGI is up to date (3.17).
    Compress::Zlib is up to date (1.41).
    Crypt::SSLeay is up to date (0.51).
    DBI is up to date (1.50).
    Date::Parse is up to date (2.27).
    Digest::MD5 is up to date (2.36).
    Digest::SHA1 is up to date (2.11).
    Expect is up to date (1.15).
    File::Copy::Recursive is up to date (0.19).
    File::Scan::ClamAV is up to date (1.8).
    File::Tail is up to date (0.99.3).
    Filesys::Statvfs is up to date (0.78).
    GD::Graph is up to date (1.4307).
    GD::Text::Align is up to date (1.18).
    Geo::IPfree is up to date (0.2).
    HTML::Entities is up to date (1.35).
    HTML::Tagset is up to date (3.10).
    HTML::Template is up to date (2.8).
    IO::Interactive is up to date (v0.0.3).
    IO::Scalar is up to date (2.110).
    IO::Socket::SSL is up to date (0.97).
    IO::Stty is up to date (.02).
    IO::Tty is up to date (1.02).
    Image::Size is up to date (2.992).
    List::Util is up to date (1.18).
    MD5 is up to date (2.03).
    MIME::Base64 is up to date (3.07).
    Mail::SpamAssassin is up to date (3.001001).
    Net::AIM is up to date (1.22).
    Net::DNS is up to date (0.57).
    Net::OSCAR is up to date (1.925).
    Net::SSL is up to date (2.77).
    Net::SSLeay is up to date (1.30).
    OLE::Storage_Lite is up to date (0.14).
    Parse::RecDescent is up to date (1.94).
    Quota is up to date (1.5.1).
    Readonly is up to date (1.03).
    SOAP::Lite is up to date (0.67).
    Safe::Hole is up to date (0.10).
    Spreadsheet::ParseExcel is up to date (0.2603).
    Spreadsheet::WriteExcel is up to date (2.16).
    Storable is up to date (2.15).
    Sys::Hostname::Long is up to date (1.4).
    Term::ReadKey is up to date (2.30).
    Term::ReadLine::Perl is up to date (1.0208).
    Tie::IxHash is up to date (1.21).
    Tie::ShadowHash is up to date (0.07).
    Tie::Watch is up to date (1.2).
    Time::HiRes is up to date (1.87).
    Time::Zone is up to date (2.22).
    Tree::MultiNode is up to date (1.0.10).
    URI::URL is up to date (5.03).
    Unix::PID is up to date (v0.0.6).
    XML::SAX is up to date (0.13).
    XML::Simple is up to date (2.14).
    perlmod--Install done
    GD installed ok
    Added Contact hostmaster@g1ga.net
    Loading Symbol Table... /usr/local/cpanel/etc/sym/BitchX.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/bnc.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/eggdrop.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/generic-sniffers.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/guardservices.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/ircd.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/psyBNC.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/ptlink.sym  ..Done
    Loading Symbol Table... /usr/local/cpanel/etc/sym/services.sym  ..Done
    Kill Proc Enabled
    Scanning for new mail senders.....................Done
    Scanning suexec_log.....................
    ....................
    ....................
    ....................
    ....................
    ....................
    ...............Done 
    
     
  5. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    How can this issue be solved?

    (Sorry, I had to cut everything up because of a 10K chars restriction...)

    Thanks for the info.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Does:

    yum install zlib zlib-devel

    work? If it says it's already installed, you might need to install the 32bit version as well. For that, what's the output for:

    yum list zlib*
     
  7. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    Thanks for trying to help me out...
    yum install zlib zlib-devel does the following :

    Code:
    # yum install zlib zlib-devel
    Setting up Install Process
    Setting up repositories
    update                    100% |=========================|  951 B    00:00
    base                      100% |=========================| 1.1 kB    00:00
    addons                    100% |=========================|  951 B    00:00
    extras                    100% |=========================| 1.1 kB    00:00
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package zlib.x86_64 0:1.2.1.2-1.2 set to be updated
    ---> Package zlib-devel.x86_64 0:1.2.1.2-1.2 set to be updated
    --> Running transaction check
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package openssl.x86_64 0:0.9.7a-43.8 set to be updated
    ---> Package libpng.x86_64 2:1.2.7-1.el4.2 set to be updated
    ---> Package xorg-x11-libs.x86_64 0:6.8.2-1.EL.13.25 set to be updated
    --> Running transaction check
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libfontconfig.so.1()(64bit) for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package fontconfig.x86_64 0:2.2.3-7 set to be updated
    --> Running transaction check
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    --> Processing Dependency: libz.so.1 for package: gd
    --> Processing Dependency: libz.so.1 for package: xorg-x11-libs
    --> Processing Dependency: libz.so.1 for package: freetype
    --> Processing Dependency: libz.so.1 for package: fontconfig
    --> Processing Dependency: libz.so.1 for package: openssl
    --> Processing Dependency: libz.so.1 for package: libtiff
    --> Processing Dependency: libz.so.1 for package: libpng
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    --> Running transaction check
    Error: Missing Dependency: libz.so.1 is needed by package gd
    Error: Missing Dependency: libz.so.1 is needed by package freetype
    Error: Missing Dependency: libz.so.1 is needed by package fontconfig
    Error: Missing Dependency: libz.so.1 is needed by package libtiff
    Error: Unable to satisfy dependencies
    Error: Package gd needs libz.so.1, this is not available.
    Error: Package xorg-x11-libs needs libz.so.1, this is not available.
    Error: Package freetype needs libz.so.1, this is not available.
    Error: Package fontconfig needs libz.so.1, this is not available.
    Error: Package openssl needs libz.so.1, this is not available.
    Error: Package libtiff needs libz.so.1, this is not available.
    Error: Package libpng needs libz.so.1, this is not available.
    
    The same problem again... :confused:
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    OK, try:

    rpm -e --justdb --nodeps zlib zlib-devel

    This will remove the rpms from the rpm database only. Then repeat the yum install:

    yum install zlib zlib-devel
     
  9. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    This seems to have solved the "dependencies" problems :

    Code:
    # yum install zlib zlib-devel
    Setting up Install Process
    Setting up repositories
    update                    100% |=========================|  951 B    00:00
    base                      100% |=========================| 1.1 kB    00:00
    addons                    100% |=========================|  951 B    00:00
    extras                    100% |=========================| 1.1 kB    00:00
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package zlib.x86_64 0:1.2.1.2-1.2 set to be updated
    ---> Package zlib-devel.x86_64 0:1.2.1.2-1.2 set to be updated
    ---> Package zlib-devel.i386 0:1.2.1.2-1.2 set to be updated
    ---> Package zlib.i386 0:1.2.1.2-1.2 set to be updated
    --> Running transaction check
    
    Dependencies Resolved
    
    =============================================================================
     Package                 Arch       Version          Repository        Size
    =============================================================================
    Installing:
     zlib                    x86_64     1.2.1.2-1.2      base               47 k
     zlib                    i386       1.2.1.2-1.2      base               44 k
     zlib-devel              x86_64     1.2.1.2-1.2      base               94 k
     zlib-devel              i386       1.2.1.2-1.2      base               89 k
    
    Transaction Summary
    =============================================================================
    Install      4 Package(s)
    Update       0 Package(s)
    Remove       0 Package(s)
    Total download size: 273 k
    Is this ok [y/N]: y
    Downloading Packages:
    (1/4): zlib-1.2.1.2-1.2.x 100% |=========================|  47 kB    00:00
    (2/4): zlib-devel-1.2.1.2 100% |=========================|  94 kB    00:00
    (3/4): zlib-devel-1.2.1.2 100% |=========================|  89 kB    00:00
    (4/4): zlib-1.2.1.2-1.2.i 100% |=========================|  44 kB    00:00
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing: zlib                         ######################### [1/4]
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /
    usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libz.so.1.2.1.2 and libz.so.1.2.3 in directory /usr/li
    b have same soname but different type.
      Installing: zlib                         ######################### [2/4]
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /
    usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libz.so.1.2.1.2 and libz.so.1.2.3 in directory /usr/li
    b have same soname but different type.
      Installing: zlib-devel                   ######################### [3/4]
      Installing: zlib-devel                   ######################### [4/4]
    
    Installed: zlib.x86_64 0:1.2.1.2-1.2 zlib.i386 0:1.2.1.2-1.2 zlib-devel.x86_64 0
    :1.2.1.2-1.2 zlib-devel.i386 0:1.2.1.2-1.2
    Complete!
    
    I'll let you know once /scripts/upcp has run again...

    Thanks.
     
  10. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    That solved the "Resolving depencies" problem...
    However now there are some conflicts with installed libraries :

    Code:
    ...
    Transaction Check Error:   file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.2.3-7 conflicts with file from package fontconfig-2.2.3-7
      file /usr/X11R6/lib/X11/locale/compose.dir from install of xorg-x11-libs-6.8.2-1.EL.13.25 conflicts with file from package xorg-x11-libs-6.8.2-1.EL.13.20
      file /usr/X11R6/lib/X11/locale/locale.alias from install of xorg-x11-libs-6.8.2-1.EL.13.25 conflicts with file from package xorg-x11-libs-6.8.2-1.EL.13.20
      file /usr/X11R6/lib/X11/locale/locale.dir from install of xorg-x11-libs-6.8.2-1.EL.13.25 conflicts with file from package xorg-x11-libs-6.8.2-1.EL.13.20
      file /usr/X11R6/lib/X11/config/xorg.cf from install of xorg-x11-devel-6.8.2-1.EL.13.25 conflicts with file from package xorg-x11-devel-6.8.2-1.EL.13.20
    ...
    
    Any ideas how to solve this one too?

    Thanks.
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi,

    Similar thing:

    rpm -e --justdb --nodeps fontconfig xorg-x11-libs
    yum install fontconfig xorg-x11-libs
     
  12. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    Thanks for the suggestions once again...

    yum install fontconfig shows the following problems (although it installed fontconfig) :

    Code:
    /sbin/ldconfig: libraries libexpat.so.0.4.0 and libexpat.so.0.5.0 in directory /
    usr/lib have same soname but different type.
    /sbin/ldconfig: libraries libz.so.1.2.1.2 and libz.so.1.2.3 in directory /usr/li
    b have same soname but different type.
    /sbin/ldconfig: libraries libz.so.1.2.1.2 and libz.so.1.2.3 in directory /usr/li
    b have same soname but different type.
    
    It seems like there are two versions installed...
    Can the older version be safely removed?

    Thanks again.
     
  13. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What output do you get with:

    ls -la /usr/lib/libz* /usr/lib/libexpat*
     
  14. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    ls -la /usr/lib/libz* /usr/lib/libexpat* show the following :

    Code:
    -rw-r--r--  1 root root 615530 Jan 24 11:32 /usr/lib/libexpat.a
    -rwxr-xr-x  1 root root    706 Jan 24 11:32 /usr/lib/libexpat.la*
    lrwxrwxrwx  1 root root     17 Jan 24 11:32 /usr/lib/libexpat.so -> libexpat.so.0.4.0*
    lrwxrwxrwx  1 root root     17 Jan 24 11:32 /usr/lib/libexpat.so.0 -> libexpat.so.0.5.0*
    -rwxr-xr-x  1 root root 410851 Jan 24 11:32 /usr/lib/libexpat.so.0.4.0*
    -rwxr-xr-x  1 root root 123496 Feb 22  2005 /usr/lib/libexpat.so.0.5.0*
    -rwxr-xr-x  1 root root  71716 Jul 21  2005 /usr/lib/libz.a*
    lrwxrwxrwx  1 root root     15 Apr  3 18:29 /usr/lib/libz.so -> libz.so.1.2.1.2*
    lrwxrwxrwx  1 root root     13 Apr  3 18:29 /usr/lib/libz.so.1 -> libz.so.1.2.3*
    -rwxr-xr-x  1 root root  62248 Jul 21  2005 /usr/lib/libz.so.1.2.1.2*
    -rwxr-xr-x  1 root root  96431 Feb  9 14:14 /usr/lib/libz.so.1.2.3*
    
    Thanks.
     
  15. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I'd be tempted to have a play with those files and rename out of the way the lesser versions and point the .so to the latest ones.
     
  16. Bdzzld

    Bdzzld Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Hi Chirpy,

    Thanks for your advise in getting rid of that many issues...
    It seems like the latter issue solved itself... I'm no longer getting the /sbin/ldconfig errors, although I did not change a thing...

    Thanks a lot for all your help... :)
     
Loading...
Similar Threads - Resolving Dependencies problem
  1. Jull Weber
    Replies:
    3
    Views:
    420

Share This Page