Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Restart of pdns required after adding _dmarc

Discussion in 'Bind/DNS/Nameserver' started by rpvw, May 21, 2018.

  1. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    666
    Likes Received:
    221
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    cPanel v70.0.43 + Cloudlinux 2.6.32-896.16.1.lve1.4.53.el6.x86_64 + Kernelcare - using the standard Paper Lantern theme, and everything patched up-to-date.

    I have been struggling all day to get a new _dmark entry to resolve for a domain.

    The dmarc entry was recorded using the cPanel Zone Editor, and was reported as being successfully added, and could be seen as a new valid entry in the Zone Records list.

    Tried Synchronize DNS Records but this achieved nothing.
    Tried deleting and re-adding the record - nothing.
    Stole Infopro's whisky - didn't help :(

    Only after restarting the pdns DNS Server (PowerDNS) did the new dmarc entry get published.

    I have not tried publishing any other type of entry, so it is possible this is limited to _dmarc, but perhaps it needs checking out.

    I worry that users (who don't have access to restart daemons) will get frustrated if they make DNS entries in their cPanel Zone Editor, and then don't see a result.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    1,350
    Likes Received:
    90
    Trophy Points:
    103
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @rpvw

    I've been attempting to replicate this today here's what I've done so far.

    1. Went to WHM>>Service Configuration>>Nameserver Selection and switched to power dns
    2. Went to cPanel>>Domains>>Zone Editor -> clicked manage next to the domain I wanted to modify
    3. pulled down the drop down next to Add Record and selected Add DMARC Record
    4. Added the default DMARC
    5. Used the search to find the dmarc record and ensure it existed
    dmarc.png
    6. Checked the DNS zone file for its existence:
    Code:
    grep dmarc /var/named/example.net.db
    _dmarc    14400    IN    TXT    v=DMARC1\;p=none\;sp=none\;adkim=r\;aspf=r\;pct=100\;fo=0\;rf=afrf\;ri=86400
    7. Used dig to check if it's been updated:
    Code:
    dig txt _dmarc.example.net +short
    "v=DMARC1;p=none;sp=none;adkim=r;aspf=r;pct=100;fo=0;rf=afrf;ri=86400"
    And couldn't replicate it not being published. Throughout the entire time I didn't restart pdns either.
    You mention Synchronize DNS Records here - are you using a DNS Cluster?

    maybe @Infopro found out about the whiskey? :P
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Infopro likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice