The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Restarting DNS/NameServer (BIND)

Discussion in 'Bind / DNS / Nameserver Issues' started by NobeleeNa, Jun 11, 2004.

  1. NobeleeNa

    NobeleeNa Active Member

    Joined:
    May 26, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Makassar, Sulawesi Selatan - INDONESIA
    When I'm trying to restart DNS/NameServer, i got this message.

    Attempting to restart bind
    Waiting for bind to restart.... . . . . . . . . . . finished.

    rndc: connect failed: connection refused bind status

    bind started ok

    Can anyone explain what is the meaning of "rndc: connect failed: connection refused bind status"?
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
  3. MarcoAA

    MarcoAA Registered

    Joined:
    Jun 14, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    same following the tutorial the error continues, would anybody have something to increase?

    Thanks
     
  4. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Check to see if the following is already commented out.
    pico /etc/sysconfig/named and comment out the 'ROOTDIR=' (put a # in front).
     
  5. MarcoAA

    MarcoAA Registered

    Joined:
    Jun 14, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks,

    resolved problem with his help.

    Best Regards
     
  6. Darkfire001

    Darkfire001 Member

    Joined:
    Jun 14, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hmm, I followed the steps to the detail, but I get this error now:

    Stopping named: rndc: no key definition for name rndc-key
    [FAILED]
    touch: creating `/var/lock/subsys/named': No space left on device ]
    root@server [/scripts]# Stopping named: rndc: no key definition for name rndc-ke

    In shell.

    All help is appreciated.
     
  7. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
  8. Darkfire001

    Darkfire001 Member

    Joined:
    Jun 14, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Checked it out and changed one more key to not have the hypen.

    But doesnt seem to fix the problem.
     
  9. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You might want to post/search at webhostingtalk.com as there are a couple of sysadmin people on the froums who can give you additional trouble shooting options.
     
  10. Darkfire001

    Darkfire001 Member

    Joined:
    Jun 14, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    :( Still getting this error, and went to WHT for help, but althrough I am not the only one with this problem. I cant seem to find any help.
     
  11. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Sent you a PM.
     
  12. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    What was the PM?
     
  13. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    Open up /etc/named.conf

    post maybe the first 10 lines I guess so I can see what you see, should see something that has rndc-key or rndckey in it locahost, etc etc
     
  14. miguex

    miguex Registered

    Joined:
    Oct 6, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Argentina!!
    Rootdir

    After of this: pico /etc/sysconfig/named and comment out the 'ROOTDIR=' (put a # in front).

    and then with "service named restart"

    I got that error:
    "named has failed, please contact the sysadmin (result was "named is not running"). "


    I am not sure "put a # in front" that is :
    "# ROOTDIR=/var/named/chroot " or
    "ROOTDIR=/var/named/chroot # " or
    "ROODIR = #" or
    what?

    I did change all like above and it still does not work. Same error" named has failed, please contact the sysadmin (result was "named is not running"). "

    Anyone'd help me? thank you very much!.

    Note: I tried everything with changing rndckey, fixndc, etc.... and nothing...
    and I am using FEDORA.

    :confused:
     
    #14 miguex, Oct 25, 2004
    Last edited: Oct 25, 2004
  15. jblack

    jblack Member

    Joined:
    Nov 17, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1

    The problem here was that /var partition is filled up. Notice the error message "No space left on device"
     
Loading...

Share This Page