The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Restore Nobody User...

Discussion in 'General Discussion' started by NoDoze, Apr 13, 2005.

  1. NoDoze

    NoDoze Active Member

    Joined:
    Mar 5, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Francisco, CA
    Ok, I had an issue with spam coming from the Nobody user...Hence in my dumb tired stooper, I deleted the Nobody user in an attempt to solve the problem...However, as many of you know this caused a mess of problems...

    Dispite, I have since resolved the spam issues....

    I remade the Nobody user, but I don't think it has the correct settings...

    I also created a www user for apache, so apache works now...via easyapache...

    but... PHP is still offline....

    I think restoring the Nobody user should solve these issues, but not sure what the settings would be....

    Can someone give me some advise?

    I'd really appreciate it, thanks.

    CentOS 3.4 w/CPanel
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The nobody user is usually configured under UID and GID 99, so:

    /etc/passwd:

    nobody:x:99:99:Nobody:/:/sbin/nologin

    /etc/shadow:

    nobody:*:12648:0:99999:7:::

    /etc/group:

    nobody:x:99:

    /etc/gshadow:

    nobody:::

    That should be all you need. If you created nobody with a different UID or GID you may have to go looking for any files created under it and chown them to 99:99
     
  3. NoDoze

    NoDoze Active Member

    Joined:
    Mar 5, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    San Francisco, CA
    Ok, thanks, that fixed everything...except ssi for some reason...
     
Loading...

Share This Page