The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Restored account: emails all return 535 "Authentication failed"

Discussion in 'E-mail Discussions' started by joshncsu, Mar 23, 2012.

  1. joshncsu

    joshncsu Registered

    Mar 23, 2012
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    The email of several accounts/domains that have been restored after being terminated no longer works, by returning an "authentication failed" 535 response. I'm not using some web client for mail, all this happens by interacting with Net/SMTP.php directly. The code is correct because it works on hundreds of other accounts. I believe the only accounts that are returning this error are ones that have been restored.

    I've tried dozens of solutions I've found online, and none have worked. Some of the things I've done/checked include:

    * Confirm that /home/username/etc is owned by username:mail (recursively)
    * All directories through /home/username/etc/domain are executable for all, files under etc/ have permission 640
    * Checked that the hashed password in shadow matches the unhashed password. It looks correct (I have other working accounts that use the same password/hash combination).
    * Suspended/unsuspended the account
    * /home/username/mail has correct ownership & permissions
    * Ran /scripts/upcp --force and /scripts/eximup --force
    * Restarted exim via /etc/init.d/exim
    * Verified that the MX DNS is points to the same ip address cpanel runs on (as the same case with other account domains that are working on)

    Any help will be very appreciated. I've been working on this for days and clients are getting very frustrated that.
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Oct 2, 2010
    Likes Received:
    Trophy Points:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator

    Please try running the following (when noting that various locations appear to have the correct permissions, this script will ensure they should have the correct permissions):

    /usr/local/cpanel/scripts/mailperm --verbose username
    Please replace username with the cPanel username. If that does not work, please check the ownership appears correct:

    Please replace with the domain that is not functioning for email authentication.

    If the above do not work, please simply try resetting the password for one of the email accounts to see if it then works. Please also try creating a new email account to see the results. If you see any errors for email password change or email account creation in /usr/local/cpanel/logs/error_log, please post the error here.

    If all else fails, please submit a ticket using WHM > Support Center > Contact cPanel or using the link in my signature. If possible, please post the ticket number here after opening one for tracking purposes.


Share This Page