The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Restoring packages to accounts

Discussion in 'General Discussion' started by spcook, Sep 9, 2009.

  1. spcook

    spcook Registered

    Joined:
    May 11, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hey got a problem I can't find a fix for:

    Just did a server migration from one to another, copying over all accounts/data/settings. Everything worked out well except for the packages. All the packages got moved over and they are still setting quotas and feature sets properly except that under List Accounts it is showing many of the account packages as "unknown" while some do have the correct packages listed.

    Is there a way to force cPanel/WHM to restore those listed packages or some other script or setting that I am missing?

    Thanks for your time!
     
  2. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    The features and packages are actually not migrated!

    Instead, the original limits and package name are stored but the
    actual package and feature lists themselves are not transferred.

    You can actually go grab the files on your old server and manually
    transfer them if you would like your old package on your new server:

    /var/cpanel/features
    /var/cpanel/packages

    I think Cpanel designed things this way to prevent conflicts and / or overwriting of existing plans and features when moving one account to another.
     
  3. dannydesiliva

    dannydesiliva Member

    Joined:
    Sep 5, 2009
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I work with Alex on the same project, and I think I have narrowed down the problem. We have views that reference functions in a package within the same schema. Some reason pg_restore/pg_dump does not recognize the dependencies between this view we have and the function that exist in a package. We have the -o specified in our pg_dump script, and I am assuming the current pg_restore command defaults to oid-order. I remember the older version of pg_restore allows you specific the item restore order. Is there a way get around this problem???

    Ken

    ___________________________________________________________________________________________________

    Regards..

    snoozer bed | washington printers | how to beat a drug test
     
    #3 dannydesiliva, Sep 12, 2009
    Last edited: Sep 14, 2009
  4. tata13

    tata13 Active Member

    Joined:
    Feb 8, 2006
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Jakarta
    I have this problem to

    i can fix this by upgrading the account to the account package. but i cannot do it for multiple account . Is there any quick way for fix packages account
     
  5. botakedan

    botakedan Member

    Joined:
    Sep 23, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    could you please help with the command line to grab that packages and features ?
     
Loading...

Share This Page