restrict the smtp server to be used by other domains

Operating System & Version
Centos 7.9
cPanel & WHM Version
90.0.17

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,472
1,005
313
cPanel Access Level
Root Administrator
Hey there, @indiego!

I'm not completely sure what you mean. Are you saying you want only your local domains to be able to send email? If so, we have the option to limit what accounts can access the SMTP service in WHM >> Tweak Settings with this value:

"Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)"

If you have that option enabled, only verified users will be able to send messages from your machine, which can help prevent spam from scripts. If you're looking for something different just let me know!
 

indiego

Member
Oct 30, 2019
6
3
3
jakarta
cPanel Access Level
Website Owner
Hey there, @indiego!

I'm not completely sure what you mean. Are you saying you want only your local domains to be able to send email? If so, we have the option to limit what accounts can access the SMTP service in WHM >> Tweak Settings with this value:

"Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)"

If you have that option enabled, only verified users will be able to send messages from your machine, which can help prevent spam from scripts. If you're looking for something different just let me know!
hi @cPRex
thank you for your response, yes this is what i mean.

i have done this but other domains still can send emails
for exampe i used gmail and smtp authentication
used my domain, and still sent
 
Last edited:

indiego

Member
Oct 30, 2019
6
3
3
jakarta
cPanel Access Level
Website Owner
Thanks for the additional details. I would still expect that to work, as that would be the same connection and authentication method as a client connecting with a tool like Outlook or Thunderbird.
hi @cPRex thank you for your response ,
there is other domain I use cpanel other hosting provider services can't send with a differend domain, the error “smtp error 550 your from gmail address must match your authenticated email domain. treating this a spofed email”. i want my other server set like that condition.
 
Last edited: