The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Resuming FTP Uploads Broken after Hostname Change

Discussion in 'General Discussion' started by Mobius1, Jan 26, 2012.

  1. Mobius1

    Mobius1 Member

    Joined:
    Aug 19, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hiya :)

    I don't know whether the two are connected, but shortly after I changed the hostname via WHM, I can no longer resume an upload via FTP once it has been paused. Once I unpause it, my client asks if I would like to overwrite the file instead of resuming the upload.

    Contents of proftpd.conf:

    Code:
    # This is a basic ProFTPD configuration file (rename it to 
    # 'proftpd.conf' for actual use.  It establishes a single server
    # and a single anonymous login.  It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.
    
    ServerName			"ProFTPD"
    AuthUserFile /etc/proftpd/passwd.vhosts
    ServerType			standalone
    DeferWelcome			off
    DefaultServer			on
    DefaultRoot ~ !wheel
    
    # Port 21 is the standard FTP port.
    AuthPAM off
    TransferLog /usr/local/apache/domlogs/ftpxferlog
    UseReverseDNS off
    IdentLookups off
    
    <IfModule mod_tls.c>
        TLSEngine on
        TLSProtocol SSLv23
        TLSRequired off
        TLSRSACertificateFile /etc/ftpd-rsa.pem
        TLSRSACertificateKeyFile /etc/ftpd-rsa-key.pem
        TLSVerifyClient off
        TLSCipherSuite HIGH:MEDIUM:+TLSv1:!SSLv2:+SSLv3
        TLSOptions NoSessionReuseRequired
    </IfModule>
    Port				21
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask				022
    
    # Set the user and group that the server normally runs at.
    User				nobody
    Group proftpd
    
    # Normally, we want files to be overwriteable.
    <Directory />
      AllowOverwrite		on
    </Directory>
    
    # A basic anonymous configuration, no upload directories.
    <Anonymous ~ftp>
    UseFtpUsers on
    RequireValidShell off
    
      User				ftp
      Group				ftp
      # We want clients to be able to login with "anonymous" as well as "ftp"
      UserAlias			anonymous ftp
    
      <Limit LOGIN>
        DenyAll
      </Limit>
      # Limit the maximum number of anonymous logins
      MaxClients			10
    
      # We want 'welcome.msg' displayed at login, and '.message' displayed
      # in each newly chdired directory.
      DisplayLogin			welcome.msg
      DisplayChdir		.message true
    
      # Limit WRITE everywhere in the anonymous chroot
      <Limit WRITE>
        DenyAll
      </Limit>
    
    </Anonymous>
    
    
     
    #1 Mobius1, Jan 26, 2012
    Last edited: Jan 26, 2012
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It looks like the "AllowStoreRestart" is not enabled in your /etc/proftpd.conf file. This directive is documented here:

    Allow Store Restart


    Please try enabling it, and let us know if the issue persists. To enable this directive, you should change the following:

    Code:
    <Directory />
      AllowOverwrite		on
    </Directory>
    To:

    Code:
    <Directory />
      AllowOverwrite		on
      AllowStoreRestart             on
    </Directory>
    Then, restart ProFTPd on your server.

    Thank you.
     
  3. Mobius1

    Mobius1 Member

    Joined:
    Aug 19, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Brilliant, it worked!

    Thank you very much!
     
Loading...

Share This Page