The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

retry time not reached for any host after a long failure period

Discussion in 'General Discussion' started by spaceman, Sep 23, 2005.

  1. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    I *had* (past tense) a problem with my resolv.conf which meant that exim was failing to send messages to certain domains for a long period.

    Now this problem with resolv.conf is fixed, BUT exim has decided that, because certain domains went unresolved for so long (4-5 days), it's not going to try again for a while to send to these domains (even though the domains are absolutely fine).

    ---

    http://www.exim.org/exim-html-4.20/doc/html/FAQ_6.html

    Q0620: Why does Exim bounce messages without even attempting delivery, giving the error retry time not reached for any host after a long failure period?

    A0620: This message means that all hosts to which the message could be sent have been failing for so long that the end of the retry period (typically 4 or 5 days) has been reached. In this situation, Exim still computes a next time to retry, but any messages that arrive in the meantime are bounced straight away. You can alter this behaviour by unsetting the delay_after_cutoff option on the smtp transport. Then Exim will try most messages for those hosts once before giving up.

    ---

    So my problem is that I have to convince exim that a particular email address is absolutely fine to send to. But when an email on the server gets created (via a web form) it bounces immediately as per Q0620 above:

    2005-09-23 15:18:30 1EIhpG-0000mj-90 ** abc@domain.com.au R=lookuphost T=remote_smtp: retry time not reached for any host after a long failure period

    So I don't want to reset this behaviour as per the instructions in A0620. What I want to do is to tell Exim "I don't give a flying xxx about the time you've computer to retry again, RETRY NOW!'

    Any takers? The web form people are filling in is for sales enquiries, and my hosting customer hasn't had any for a week or two - not good!! :eek:
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It usually starts working again if you select one of the offenders in WHM > Mail Queue Manager > and hit the Deliver Now link for that one email. If it is pursuaded to actually send the rest should follow. If they don't then you may need to fiddle with the queue parameters at the end of the exim configuration editor. Another stab would be to try:

    exim -qff
     
  3. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for your help.

    I've tried executing exim -qff on two servers. It can take quite some time to complete, can't it? :)

    It worked well on one of my servers. The other one returned this:

    root@saturn [~]# exim -qff
    ide0(3,4): write failed, user block limit reached.
    ide0(3,4): write failed, user block limit reached.
    ide0(3,4): write failed, user block limit reached.
    root@saturn [~]#

    This is probably off-topic from my original post, but can anyone throw me a bone about what's going on here??
     
  4. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
  5. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16

    A question with regards to 'exim -qff'. Given that 'exim -qff' appears to work better than 'Attempt to deliver all messages in Queue', do you recommend setting up a cron job to execute this command regularly, say, once a day? I've seen other threads discussing *how* to setup a cron job for this - my question is: is the cron job recommended?

    Thanks :)
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No, I wouldn't really recommend it since exim does queue management itself every x minutes depending on what values you have set in WHM > Tweak Settings > for the queue processing interval and also the settings that you have at the bottom of /etc/exim.conf which you can change through the Exim Configuration Editor. That would be the best place to set the policy that you want on retrying queued items.
     
  7. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    Thanks v. much.
     
Loading...

Share This Page