Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Return-Path: <root@vps> instead of Return-Path: <root@vps.domain.tld>

Discussion in 'E-mail Discussion' started by estoresite, Jul 10, 2018.

  1. estoresite

    estoresite Member

    Joined:
    Jun 24, 2018
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Hi Y'all,

    I haven't seen anyone else with this issue, resolved or otherwise and, I haven't been able to figure it out myself.

    I have recently migrated from an old VPS to a new VPS with a different hosting company.

    The problem I'm seeing is that, when I view mail headers of email sent from the server, to my gmail account (other than SMTP), such as PHPMail from Wordpress sites & system emails from the server, I'm seeing;

    spf=neutral (google.com: xxx.xxx.xxx.xxx is neither permitted nor denied by best guess record for domain of root@vps) smtp.mailfrom=root@vps

    - instead of -

    spf=pass (google.com: domain of root@vps.domain.tld designates xxx.xxx.xxx.xxx as permitted sender) smtp.mailfrom=root@vps.domain.tld


    ..and the return path line reads as;

    Return-Path: <root@vps>

    - instead of

    Return-Path: <root@vps.domain.tld>

    See how the "domain.tld" is missing from the hostname in the email headers?

    I'm thinking there has to be something in the VPS setup that my previous host had configured for me, that my current host has not configured for me.

    I've combed through WHM settings and can't figure out what I need to do to correct this.

    Any ideas?

    My server is;

    Linux
    EasyApache4
    CENTOS 7.5
    cPanel/WHM v72.0.7


    Thanks in advance.
     
  2. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    1,783
    Likes Received:
    132
    Trophy Points:
    118
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @estoresite

    On the server that's just showing up as "vps" can you run the following:

    Code:
    hostname
    and reply here with the output? What it looks like is though you may have set your hostname at some point it reverted back to just vps - this typically occurs after a restart.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. estoresite

    estoresite Member

    Joined:
    Jun 24, 2018
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Thanks for replying Lauren,

    The result is attached.

    In the WHM interface it reads the whole hostname.

    Should I just resave it?

    Thanks.
     

    Attached Files:

  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,678
    Likes Received:
    71
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    Yes
    guessing its openVZ
    we have always had this issue when its started from the WHM GUI issue comes and goes
    we just just stick an rc.local script to reload the correct hostname in to /etc/hosts
    on reboot
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. estoresite

    estoresite Member

    Joined:
    Jun 24, 2018
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    That did the trick. Awesome. Thanks you two.
     

    Attached Files:

  6. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    1,783
    Likes Received:
    132
    Trophy Points:
    118
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @estoresite

    Great! I'm glad that fixed the issue. I would suggest if it is a VZ server that you request your provider (if you don't have access to the host node) change the container name to your hostname so that this doesn't occur after every restart - at least this is what I've been told resolves the issue. The advice given by @dalem will also work.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. estoresite

    estoresite Member

    Joined:
    Jun 24, 2018
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Hi @cPanelLauren

    This is a xen server. Will that make any difference to either of the long-term solutions that you and @dalem suggested?

    Thanks again.
     
  8. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    1,783
    Likes Received:
    132
    Trophy Points:
    118
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,678
    Likes Received:
    71
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    We never have issues with XEN Just OpenVZ
    Do not know your providers infrastructure,
    But its possible that the hostname is set to VPS and at every reboot it sets the
    network settings and hostname.
    If you have access to a panel to set the hostname or your provider you can change it permanently.

    if not my rc.local solution works
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice