The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

return-path

Discussion in 'General Discussion' started by ckh, Mar 9, 2004.

  1. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    I've been fighting this problem for a while.

    I'm getting username@subdomain.myservername.com as the return-path header instead of what I want it to read which is bounce@mydomain.com which is the domain name with the php email script.

    I've searched the forums and tried the suggestions:

    Added to my exim.conf in the main configuration area

    untrusted_set_sender = *
    trusted_users = nobody

    I'm also using the -f option in php mail function, an example would be:

    mail("$aemail", $subject, $body, "FROM: $nlemail","-f$nlemail");

    This was working earlier last month and just stopped for some reason without me making any changes to the script or to exim.conf. After I had fixed it the first time I didn't notice it until about 3 weeks later.

    cPanel said it was a piping problem with the php mail function however that doesn't explain why it was working and suddenly stopped.

    Anyone else having the same problem or have a fix?

    Thanks

    CKH

    cPanel.net Support Ticket Number: 42217
     
  2. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    this is actually correct behaviour. there is a big difference between a return-path header and a from header. return-paths have to follow rfc and are mostly only used when something bounces.
     
  3. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    And there is my problem. When the return-path is addressed to

    username@my.servername.com

    instead of what I want of

    bounce@mydomain.com

    no one gets a bounce message, which I need to clean up my mailing list of bad email addresses and adjust my membership accordingly.

    PHP says the -f option should do it.

    Exim says if you add a trusted user, then you can use the -f option.

    But, it just isn't working.

    CKH
     
  4. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    that is why php driven mailing list managers do not cut it.
    use mailman, it comes with cpanel, is free and works just fine!
     
  5. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    One of the nice things about using my php mailer is that the mysql database is used by it. I don't have to be constantly updating it manually. When my members join or quit, their email address and membership is automatically deleted from the system.

    Using mailman would require me to be constantly updating the mail list.

    CKH
     
  6. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    Found a solution.

    I had been adding

    trusted_user = Nobody

    in the etc/exim.conf file.

    I added it to /usr/local/etc/exim/configure

    and it started working.

    CKH
     
  7. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    I do not have a /usr/local/etc/exim/configure
    are you sure you have the right file?

    And with the trusted_user = Nobody in the /etc/exim.conf it fails to start.
     
  8. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    I'm running FreeBSD and that's where it's located for me.

    I'm by far, no expert, but the

    trusted_user = nobody

    should be put in the exim.conf file in the section below where it starts out with MAIN CONFIGURATION SETTINGS.

    If that doesn't work, what you can try is log in via ssh and type:

    # sendmail -bV

    and this will tell you the location of the configuration file that is used.

    CKH
     
  9. spaceman

    spaceman Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    481
    Likes Received:
    0
    Trophy Points:
    16
    Shouldn't that be

    trusted_users = nobody

    Straight from the exim online manual:

    ---
    trusted_users
    Type: string list
    Default: unset

    If this option is set, any process that is running as one of the listed users is trusted. The users can be specified numerically or by name. See section 5.2 for details of what trusted callers are permitted to do. If neither trusted_groups nor trusted_users is set, only root and the Exim user are trusted.
    ---

    Maybe using trusted_user (singular) would cause exim to fail to restart?
     
  10. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    You're right. I originally had the S on the trusted_users in earlier posts, but, I must have typed it instead of copy and paste and left the S out.

    CKH
     
Loading...

Share This Page