SOLVED Reverse DNS does not match SMTP Banner

DennisMidjord

Well-Known Member
Sep 27, 2016
280
43
78
Denmark
cPanel Access Level
Root Administrator
Hi,

MXToolBox reports that our reverse DNS does not match the SMTP Banner even though it should.
I've made the following changes:
Exim configuration:
Send mail from account’s dedicated IP address: Off
Reference /etc/mailhelo for outgoing SMTP HELO: On
Reference /etc/mailips for outgoing SMTP connections: On

Code:
smtp_banner = "${smtp_active_hostname} ESMTP Exim ${version_number}  \#${compile_number} ${tod_full} \n   We do not authorize the use of this system to transport unsolicited, \n   and/or bulk e-mail."

smtp_active_hostname =
${lookup{$interface_address}lsearch{/etc/mail_reverse_dns}{$value}{$primary_hostname}}

message_id_header_domain = $smtp_active_hostname
/etc/mailips:
Code:
*: 10.0.0.251
/etc/mail_reverse_dns:
Code:
10.0.0.251: pro5mail.example.com
/etc/mailhelo:
Code:
* : pro5mail.example.com
When trying to telnet, it reports the correct hostname:
Code:
[[email protected] ~]# telnet pro5mail.example.com 25
Trying *.*.*.251...
Connected to pro5mail.example.com.
Escape character is '^]'.
What could the issue be?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Sometimes it's a false positive from the MXToolBox website due to the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam." option under the "ACL Options" tab in "WHM >> Exim Configuration Manager >> Basic Editor". See:

SOLVED - Reverse DNS does not match SMTP Banner (Problem)

Thank you.