The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rewrite not working after restore?

Discussion in 'General Discussion' started by rushman, Oct 4, 2005.

  1. rushman

    rushman Active Member

    Sep 21, 2003
    Likes Received:
    Trophy Points:
    It appears that mod rewrite isn't working properly after a restore. It is compiled for apache, the module exists, and everything seems to be setup ok, however (and I notice this will all sites running gallery) that rewrite isn't takeing affect.

    PHP version 4.3.11
    no phpsuexec

    I don't get it??

    htaccess is working, as I can still do simple options like password protection. The contents of a gallery htaccess file is:

    php_value post_max_size 20971520
    php_value upload_max_filesize 20971520
    php_value magic_quotes_gpc off
    <IfModule sapi_apache2.c>
    php_value session.bug_compat_warn off
    <IfModule mod_php4.c>
    php_flag session.bug_compat_warn off
    Options -Indexes +FollowSymLinks
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^([^\.\?/]+)/([0-9]+)$      /view_photo.php?set_albumName=$1&index=$
    2       [QSA]
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$     /view_photo.php?set_albumName=$1
    &id=$2  [QSA]
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^([^\.\?/]+)/$      /$1     [R]
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^([^\.\?/]+)$       /view_album.php?set_albumName=$1        [QSA]
    # END Gallery section.  Add User changes below this line

Share This Page