The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RewriteOptions MaxRedirects

Discussion in 'General Discussion' started by MrNone, Apr 29, 2006.

  1. MrNone

    MrNone Active Member

    Joined:
    Sep 25, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    My load avarage too much. I found alot of error log on apache error_log file.

    [Sun Apr 30 01:24:57 2006] [error] [client 66.249.66.174] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

    What is this :rolleyes:
     
  2. MrNone

    MrNone Active Member

    Joined:
    Sep 25, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
  3. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sounds like a mod_rewrite script on someone's site is caught in a loop. Apache will kill the request after so many loops to keep the server from eating itself alive.
     
  4. MrNone

    MrNone Active Member

    Joined:
    Sep 25, 2004
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    where is this settings?
     
  5. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    The settings would need to be in /usr/local/apache/conf/httpd.conf - they may not currently be there.

    Take a look at the Apache documentation for further information: http://httpd.apache.org/docs/1.3/
     
  6. r00t pAsSw0rd

    r00t pAsSw0rd Active Member

    Joined:
    Sep 14, 2006
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Same problem here...

    Apache logs:

    mod_rewrite: maximum number of internal redirects reached

    I restarted the vps as well.

    apachectl configutest shows syntax ok
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    NightStorm has given you the answer above. You need to trawl through all your .htaccess files and find the culprit and fix it.
     

Share This Page