The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RewriteRule directive is forbidden

Discussion in 'General Discussion' started by ITDevil, Oct 24, 2007.

  1. ITDevil

    ITDevil Member

    Joined:
    Aug 22, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi, How are you? I am having a problem with on of my sites after doing a restore via cpmove file.

    cPanel is showing the fallowing error. I am have tried "/scripts/upcp --force" "/scripts/fixeverythign" even recompiled the apache via WHM "Apache Update" i am having the same issue.


    httpd.conf

    Code:
    RLimitMEM 292697429
    RLimitCPU 240
    
    ServerType standalone
    ServerRoot /usr/local/apache
    PidFile /usr/local/apache/logs/httpd.pid
    ScoreBoardFile /usr/local/apache/logs/httpd.scoreboard
    
    Timeout 15
    KeepAlive On
    MaxKeepAliveRequests 64
    KeepAliveTimeout 1
    MinSpareServers 10
    MaxSpareServers 15
    StartServers 15
    MaxClients 256
    MaxRequestsPerChild 64
    
    LoadModule rewrite_module     libexec/mod_rewrite.so
    LoadModule expires_module     libexec/mod_expires.so
    LoadModule php4_module        libexec/libphp4.so
    LoadModule bwlimited_module   libexec/mod_bwlimited.so
    LoadModule bytes_log_module   libexec/mod_log_bytes.so
    LoadModule auth_passthrough_module libexec/mod_auth_passthrough.so
    LoadModule security_module    libexec/mod_security.so
    LoadModule layout_module      libexec/mod_layout.so
    
    ClearModuleList
    AddModule mod_env.c
    AddModule mod_log_config.c
    AddModule mod_mime.c
    AddModule mod_negotiation.c
    AddModule mod_status.c
    AddModule mod_include.c
    AddModule mod_autoindex.c
    AddModule mod_dir.c
    AddModule mod_cgi.c
    AddModule mod_asis.c
    AddModule mod_imap.c
    AddModule mod_actions.c
    AddModule mod_userdir.c
    AddModule mod_alias.c
    AddModule mod_rewrite.c
    AddModule mod_access.c
    AddModule mod_auth.c
    AddModule mod_expires.c
    AddModule mod_so.c
    AddModule mod_setenvif.c
    <IfDefine SSL>
    AddModule mod_ssl.c
    </IfDefine>
    AddModule mod_frontpage.c
    AddModule mod_php4.c
    AddModule mod_bwlimited.c
    AddModule mod_log_bytes.c
    AddModule mod_auth_passthrough.c
    AddModule mod_security.c
    AddModule mod_layout.c
    Include "/usr/local/apache/conf/modsec.conf"
    
    Port 80
    
    <IfDefine SSL>
    Listen 80
    Listen 443
    </IfDefine>
    
    User nobody
    Group nobody
    
    ServerAdmin root@s1.xxxx.com
    DocumentRoot /usr/local/apache/htdocs
    <Directory />
           Options All
           AllowOverride All
    </Directory>
    
    <Directory "/usr/local/apache/htdocs">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
    <IfModule mod_userdir.c>
    UserDir public_html
    </IfModule>
    
    
    <IfModule mod_dir.c>
    DirectoryIndex index.html index.wml index.cgi index.shtml index.jsp index.js index.jp index.php4 index.php3 index.php index.phtml index.htm default.htm default.html home.htm
    </IfModule>
    
    AccessFileName .htaccess
    
    <Files ~ "^error_log$">
    Order allow,deny
    Deny from all
    Satisfy All
    </Files>
    
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
        Satisfy All
    </Files>
    
    
    UseCanonicalName On
    
    <IfModule mod_mime.c>
        TypesConfig /usr/local/apache/conf/mime.types
    </IfModule>
    
    DefaultType text/plain
    
    <IfModule mod_mime_magic.c>
        MIMEMagicFile /usr/local/apache/conf/magic
    </IfModule>
    
    HostnameLookups Off
    
    ErrorLog /usr/local/apache/logs/error_log
    
    LogLevel warn
    
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    LogFormat "%{Referer}i -> %U" referer
    LogFormat "%{User-agent}i" agent
    
    
    ServerSignature Off
    
    NameVirtualHost 6x.xxx.xx.80:80
    
    
    <VirtualHost 6x.xxx.xx.80>
    ServerName s1.xxx.com
    DocumentRoot /usr/local/apache/htdocs
    </VirtualHost>
    
    
    <Location /whm-server-status>
        SetHandler server-status
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Location>
    ExtendedStatus On
    
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    </IfModule>
    
    httpd.conf (account having problem)
    Code:
    <VirtualHost 66.212.28.80>
    ServerAlias www.xxx.com
    ServerAdmin webmaster@xxx.com
    DocumentRoot /home/avenue/public_html
    User xxx
    Group xxx
    ServerName xxx.com
    
    <IfModule mod_userdir.c>
      Userdir disabled
      Userdir enabled xxx
    </IfModule>
    
    <IfModule mod_suphp.c>
      suPHP_UserGroup xxx xxx
    </IfModule>
    <IfModule mod_php4.c>
      php_admin_value open_basedir "/home/xxx:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
      php_admin_value open_basedir "/home/xxx:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    
    User avenue
    Group avenue
    BytesLog /usr/local/apache/domlogs/xxx.com-bytes_log
    CustomLog /usr/local/apache/domlogs/xxx.com combined
    ScriptAlias /cgi-bin/ /home/xxx/public_html/cgi-bin/
    </VirtualHost>
    .htaccess
    Code:
    Options +FollowSymlinks
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    any idea how to fix it?

    Thank You!
     
Loading...

Share This Page