The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RH 7.2 doesnt support courier for maildir conversion?

Discussion in 'E-mail Discussions' started by jackie46, Nov 10, 2005.

  1. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    I wanted to upgrade 1 box to courier. When i started the conversion the error log said it couldnt upgrade courier. I was told by one of the Cpanel staff memebers today that we will not be able to do the maildir conversion because its not supported on RedHat 7.2???? :confused:

    Is this true? There must be thousands of boxes still running it. So what are we supposed to do? I dont want to be forced to update my entire box just to do this upgrade to courier. Not yet anyway. While i intend to upgrade all 7.2 boxes to RHEL im not ready to do so as yet but i dont want to be forced to upgrade the OS just to upgrade to maildir. :(
     
    #1 jackie46, Nov 10, 2005
    Last edited: Nov 10, 2005
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup. The problem is that FedoraLegacy no longer support RH7.2 and so the rpms are not available to update the required OS components. You'll either need to upgrade to a non-EOL OS (and RH7.2 has been dead for a very long time) or upgrade to RH7.3 which is still being updated by FL.
     
  3. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    same problem here... my box is left broken... there should have been a check performed before the conversion started :(....

    is there a way to revert now?
     
  4. xerophyte

    xerophyte Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    I would consider upgrading the OS to CentOS 4.x, not because of the maildir. Mostly because of the security issues.

    RH 7.2 has been EOL for long time and i am sure you have very old kernel with it and many more old software. Anyone should be able to install rootkit without any problem using any web howto out there.

    I really recommend to spend time to upgrade the OS to centos 4.x, which will also support the new cpanel upgrade too.
     
  5. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    This is really not a good time for an OS upgrade. But there is also a
    correction I am running
    Red Hat Linux release 7.3 (Valhalla)

    but still maildir conversion is broken.. I suspect FL dropped support since...

    What can I do?

    I m planning to upgrade sometime in the near future but I've had so many problems this month that I do not wish to extend the downtime.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    FedoraLegacy no longer exists as of the end of 2006.

    This means all the distros they supported will no longer receive updated RPMs from them.

    RedHat 7.3, 9, FedoraCore 1-4
     
  7. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Oh well... the strange thing however is that I am getting an error about cpanel not being able to save it's data... not a software error... makes me wonder.
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Can you paste the errror in here, or a screen shot of it?
     
  9. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    sorry to mess in like this but redhat 7.2 is antique. i respect the fact that you don't want to rebuild your box but redhat 7.2 has a TON of bugs and public exploits. seems very irresponsable to me to run a server on redhat 72. unless you keep it on the internal network and not accessible from outside.

    yet, that means OLD software.
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  11. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Despite the name of this thread, my question is to hedgehog, who is running RH 7.3 (still supported by cPanel).

    We know RH 7.2 is ancient, unsupported, etc etc. No need to voice more comments on that :D
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Ah, didn't spot that - such is the danger from re-opening old threads.
     
  13. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Yeah, I wasn't targetting anyone with my comment, just a general notice before thigns got out of hand.
     
Loading...

Share This Page