Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

RHEL3 + Exim: correct permissions for /mail directoy?

Discussion in 'E-mail Discussion' started by benlancaster, Nov 5, 2005.

  1. benlancaster

    benlancaster Registered

    Joined:
    Nov 5, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    151
    Hey,

    of late, Exim's been playing up, which means my server won't send out messages at all. Here's what my /var/log/exim_mainlog kicks out when i try with PHP:

    Code:
    2005-11-05 13:32:49 1EYOA5-0003aK-0Y <= nobody@***.*** U=nobody P=local S=364
    2005-11-05 13:32:49 1EYOA5-0003aK-0Y failed to expand condition "${perl{checkspam}}" for lookuphost router: Gid 99 is not permitted to relay mail at /etc/exim.pl line 365.
    
    2005-11-05 13:32:49 1EYOA5-0003aK-0Y failed to expand condition "${perl{checkspam}}" for literal router: Gid 99 is not permitted to relay mail at /etc/exim.pl line 365.
    
    2005-11-05 13:32:49 1EYOA5-0003aK-0Y ** ben.lancaster@***.*** R=fail_remote_domains: unrouteable mail domain "***.***"
    2005-11-05 13:32:49 1EYOA5-0003aM-37 <= <> R=1EYOA5-0003aK-0Y U=mailnull P=local S=1277
    2005-11-05 13:32:49 1EYOA5-0003aK-0Y Completed
    2005-11-05 13:32:49 1EYOA5-0003aM-37 == nobody@***.*** R=localuser T=local_delivery defer (13): Permission denied: creating lock file hitching post //mail/inbox.lock.***.***.436cb481.000035de (euid=99 egid=12) 
    
    Looks like its something to do with allowing user 'nobody' to send mail, but in "Tweak Config" in WHM, this is disabled. What gives?

    Any help would be appreciated!

    B
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Edit /var/cpanel/cpanel.config and make sure this is set as follows:

    eximmailtrap=0

    Then:

    rm -fv /etc/eximmailtrap

    Should be OK then.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice