The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ridiculous

Discussion in 'General Discussion' started by Secret Agent, May 15, 2006.

  1. Secret Agent

    Secret Agent Guest

    After doing nothing but upgrading cpanel from stable to release version, many clients are getting 500 internal errors similiar to the one below:

    500 Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@client.biz and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.



    I have phpsuexec enabled also, has been for 4 months now. I've gotten at least a dozen complaints about the above error since the upgrade. Any suggestions?
     
  2. panayot

    panayot Well-Known Member

    Joined:
    Nov 18, 2004
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    what do you have in apache error log and phpsuexec error log?
     
  3. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    I'd also recommend checking the usual suspects:

    1) Script and script directory permissions and ownership correct?
    Ownership should be user:user, perms should be max 0755

    2) Check for PHP related values in .htaccess files
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    A few of our clients had the same exact problem, Secret Agent. The solution is very simple, just re-compile Apache and you should be fine.
     

Share This Page