Belaird

Well-Known Member
Jun 24, 2004
59
0
156
After the upgrade of RKHunter, I am seeing these kind of error messages when it examines the executables:

Info: prelinked files found
Performing 'known good' check...
/usr/sbin/prelink: /lib/tls/libc-2.3.4.so has a dependency cycle
/usr/sbin/prelink: /bin/cat: at least one of file's dependencies has changed since prelinking
/bin/cat [ BAD ]


Is there a way to fix this error or address the dependancy issue? Also fixing this would it cuase me any other problems that require rebuilding certain products ie WHM or Cpanel?

TIA
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,221
4
193
Minneapolis, MN
Belaird said:
usr/sbin/prelink: /lib/tls/libc-2.3.4.so has a dependency cycle
/usr/sbin/prelink: /bin/cat: at least one of file's dependencies has changed since prelinking
To fix this problem try these commands:
prelink -u -a
Then re-run rkhunter.