Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

rkhunter: possible security risk?

Discussion in 'Security' started by mediagenerator, Dec 13, 2011.

  1. mediagenerator

    Joined:
    Mar 16, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    51
    Code:
    [17:58:46] Info: Starting test name 'apps'
    [17:58:46] Checking application versions...
    [17:58:46]   Checking version of Exim MTA                    [ Warning ]
    [17:58:46] Warning: Application 'exim', version '4.69', is out of date, and possibly a security risk.
    [17:58:46]   Checking version of GnuPG                       [ OK ]
    [17:58:46] Info: Application 'gpg' version '1.4.5' found.
    [17:58:46]   Checking version of Apache                      [ OK ]
    [17:58:47] Info: Application 'httpd' version '2.2.21' found.
    [17:58:47]   Checking version of Bind DNS                    [ OK ]
    [17:58:47] Info: Application 'named' version '9.3.6-P1' found.
    [17:58:47]   Checking version of OpenSSL                     [ Warning ]
    [17:58:47] Warning: Application 'openssl', version '0.9.8e', is out of date, and possibly a security risk.
    [17:58:47]   Checking version of PHP                         [ OK ]
    [17:58:47] Info: Application 'php' version '5.3.8' found.
    [17:58:47]   Checking version of OpenSSH                     [ Warning ]
    [17:58:47] Warning: Application 'sshd', version '4.3p2', is out of date, and possibly a security risk.
    
    For one, I know that the openssl version used in centos 5 branches is outdated already. But exim? I'm just asking because couple of weeks earlier, I had a friend of mine (sec guy) run a couple of script kiddie tests on the server and he also sent me a link to a list of known exploits for the current exim version installed on my cPanel box.

    Now, should I be worried about rkhunter's results? Is there anything I could do about that?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    We are using the latest exim version on 11.31 in EDGE right now.

    The existing exim version has the security patches installed for the operating system distribution. If you know of a specific security issue that you would like to know if it has been patched for that exim version, please state the exact CVE for the security issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice