The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RLimitMEM troubles

Discussion in 'General Discussion' started by coldplug, Oct 26, 2009.

  1. coldplug

    coldplug Member

    Joined:
    Oct 26, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I'm very new here.

    I suddenly installed cPanel, Centos 5.4, VPS on Xen, with 1GB RAM.

    After transferring some web sites to new server, most of them (joomla, and similar php applications) stopped working because of errors like "fatal error: out of memory ...". After research, it turned out that reason is too low RLimitMEM parameter in httpd.conf. It had value that were set by "Memory Usage Restrictions" script from cPanel Apache Configuration.

    But here real struggle start. Value set by that script were no less than 150MB (RLimitMEM 149148672)!! Whole 150MB and this were not enough? How I know that this directive were problem? Simply, because when I raised it by ten times (1,5GB) now there is no problem in running php web sites.

    So where is a catch? I cannot understand why on Earth some php script would need more than 150MB of memory to work. Of course, it does not, my system memory usage is rarely exceedes 200MB for whole server. No way any php script need 150MB of memory here. Or do I miss something?

    You can check my munin stats here
    wrfems.info/munin/meteoadriatic.net/webserver.meteoadriatic.net.html

    The server is really not overloaded by running these php scripts that "need over 150MB of memory".

    What values do you other have for RLimitMEM directive in https.conf?

    Any comments on this are very welcome,
    thanks in advance,
    Ivan
     
    #1 coldplug, Oct 26, 2009
    Last edited by a moderator: Oct 26, 2009
  2. mistermartin75

    Joined:
    Sep 5, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Well, mine keeps setting it to either 60MB, 75MB or 100MB, while I actually want it to be 150MB (munin requires 101MB at times). I've tried to set that, but it actually seems to get ignored.
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    It is possible that the automatically-determined value for RLimitMEM may need to be adjusted or the entry removed as some custom scripts or special use cases might experience problems due to the potentially high unique requirements of each web site and varying server activity or usage levels.

    If you would like specific assistance with removing the directive from your Apache configuration please consider submitting a ticket; the link in my forums signature may be used to initiate a ticket submission.

    If you are simply needing to adjust the existing value, please reference the official Apache documentation for the directive and your specific version branch of Apache/httpd (e.g., 2.2, 2.0, or 1.3, as seen below):
    http://httpd.apache.org/docs/2.2/mod/core.html#rlimitmem
    http://httpd.apache.org/docs/2.0/mod/core.html#rlimitmem
    http://httpd.apache.org/docs/1.3/mod/core.html#rlimitmem

    For our own documentation on EasyApache3 and modifying the Apache configuration (httpd.conf) file, please see the following resources:
    Apache & cPanel/WHM
    OutsideVHost < EasyApache3 < TWiki
     
  4. mistermartin75

    Joined:
    Sep 5, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    The cause of my problem was actually CSF, so I'm sorry to have caused confusion and to have posted it here.

    But I've found out that, besides in httpd.conf, the memory limits are kept somewhere else as well, but I can't remember the exact file.

    Thank you, nonetheless, for the explanation. It is highly appreciated :)
     
  5. tkrn

    tkrn Registered

    Joined:
    Jan 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    i just had the same issue! the rlimitmem and rlimitcpu are at the top of the httpd.conf file, the first two lines at /etc/httpd/conf/httpd.conf

    removed them and it works great!
     
Loading...
Similar Threads - RLimitMEM troubles
  1. mahendrap
    Replies:
    1
    Views:
    472

Share This Page