The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rmagic.pl

Discussion in 'General Discussion' started by tabernack, Jan 16, 2002.

  1. tabernack

    tabernack Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    This script has been running for hours on one of my servers and I can\'t seem to figure out what is causing it. The script is located in the cpanel 3rdparty directory and has something to do with generating reports for analog. But I\'ve never seen it run before, and I find it strange that it\'s been running on and off for so long and consuming 98% cpu resources.

    Any ideas? :)
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    ;)
    http://support.cpanel.net/new/viewthread.php?tid=1144

    So essentially....... yea.
    Perhaps can this script run at a lower priority? I have reports of this being a pain in the @$$ from dedicated machines, and it certainly is slowing things down in our shared environment......

    99.5 % usage or above on CPU when even ONE instance of this new script runs...

    can we tune it down a bit?
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Glad I found this thread :) ... tune it down?? how about turn it off?
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Maybe reNICE the process (as lame as that sounds)... it might actually help since this is flat out perl crunching away in the background.

    I would rather not sacrifice it completely, it enhances a standard analog report by like 150% and people are liking it already.... granted I have about the same number of reports of \"apache being sluggish\"

    LIFE is GOOD
     
  5. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    99% of one of the processors,

    I murdered (killed) it on sight uesterday...

    Let\'s hope it will not screw up analog...

    Hedgy
     
  6. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Just in case,

    How can I grant it life again if the need arises?

    Hedgy
     
  7. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Just killed it again...

    It was running with the same user ID it was yesterday,... strangely, it was one of my customers\'

    Hedgy
     
  8. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Ummm... yea, that\'s normal as that perl script is instantiated by the user when they tell Analog to generate a fresh report.... so it will show up in the process tree as the user that clicked on that particular spot in his or her cpanel.

    Definitely still needs some fine tuning.
     
  9. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    You are right, and some niceness would as you previously suggested should also get things in a better shape...

    hedgy
     
  10. intrahost

    intrahost Member

    Joined:
    Dec 1, 2001
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    soooo....

    Is anything being done about this? My load averages were in the single digits (meaning like .07, .2 etc,) before and ever since rmagic, we\'ve been running 40-100 (.40, .98, etc). Is there a way to turn this off or something?
     
  11. AlaskanWolf

    AlaskanWolf Well-Known Member

    Joined:
    Aug 11, 2001
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Fremont CA
    Anyone?

    Nick yah got a kill switch for this baby, i noticed it running on free on one of my most stabliest servers, since then the loads are at a steady 4-10 daily
     
  12. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    DARKORB - please review RMAGIC.PL

    I would rather have this functionality, but not in its current state.................

    Can we run this as a lower priority please? Otherwise I\'m going to start chmoding it to nothingness and locking it so that the machines can all calm down once again.
     
  13. bdraco

    bdraco Guest

    feanor: What build are your running ? It should run with a very large nice value...
     
  14. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    latest \'n greatest...

    ==> Checking to see if you have the latest version.....Yep! 4.2.0-STABLE_35
    ==> Exiting
    .......................

    still processes skyrocket to 99.9 on most machines when they involve rmagic.pl. perhaps thats just because nobody else is doing anything .... I haven\'t really had it actual CAUSE a load rise itself for quite some time.
     
  15. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Report Magic files have wrong owner

    This is a listing of the Report Magic directory on my server:

    drwxr-xr-x 7 root root 4096 Jan 23 13:08 ./
    drwxr-xr-x 16 root root 4096 Jan 22 13:28 ../
    -rw-r--r-- 1 nobody jackdarb 7754 Jan 8 04:12 INSTALL
    -rwxr-xr-x 1 nobody jackdarb 9698 Jan 8 04:12 Install.PL*
    -rw-r--r-- 1 nobody jackdarb 1239 Jan 8 04:12 README
    drwxr-xr-x 2 root root 4096 Jan 22 13:28 Time/
    -rw-r--r-- 1 nobody jackdarb 567 Jan 8 04:12 analogo.gif
    drwxr-xr-x 3 root root 4096 Jan 22 13:28 docs/
    drwxr-xr-x 12 root root 4096 Jan 22 13:28 lang/
    -rwxr-xr-x 1 nobody jackdarb 32849 Jan 14 15:22 rmagic.pl*
    -rwxr-xr-x 1 root root 32849 Jan 23 13:08 rmagic.pl.old*
    -rw-r--r-- 1 nobody jackdarb 668 Jan 14 15:00 rmagic.sample
    -rw-r--r-- 1 nobody jackdarb 3690 Jan 8 04:12 rmlogo.gif
    -rw-r--r-- 1 nobody jackdarb 14029 Jan 8 04:12 sample.dat
    drwxr-xr-x 3 root root 4096 Jan 22 13:28 samples/
    -rw-r--r-- 1 nobody jackdarb 586 Jan 8 04:12 stylesheet.sample
    drwxr-xr-x 3 root root 4096 Jan 22 13:28 wadg/

    jdarb is a customer -- I\'m sure these files have the wrong ownership -- what user should own these files?
     
  16. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    The same instance of rmagic.pl (owned by the same customer) is stuck nightly.

    Everything else is working quite fine, except for this customer.

    Curious!

    Hedgy
     
  17. bdraco

    bdraco Guest

    Can you get an strace ?
     
  18. hedgehog

    hedgehog Well-Known Member

    Joined:
    Nov 3, 2001
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    I could... but it I had already killed it before reading your post... is there a way to spring it back to life short of waiting for it to do so?

    Hedgy
     
  19. tabernack

    tabernack Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    It seems to be running much better now. The past few days it would run consistently without pause. I\'ve been watching my server all day and they\'ve been running much better.

    BTW: I know it\'s just cosmetic, but I really like the new colors/fonts in WHM. Much much better :)
     
  20. tabernack

    tabernack Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    Still happening

    I\'ve still had problems with this script over the past couple of weeks. It seems to get stuck crunching stats for the same account:

    #637 10473 0.0 0.0 1084 416 ? SN Jan30 0:01 /usr/local/cpanel/bin/logrunner 1.0 /usr/local/cpanel/3rdparty/rmagic
    #637 10474 14.4 0.7 9860 7680 ? RN Jan30 383:35 \\_ perl /usr/local/cpanel/3rdparty/rmagic/rmagic.pl /home/careerande
    #637 685 0.0 0.0 1084 416 ? SN Jan31 0:00 /usr/local/cpanel/bin/logrunner 1.0 /usr/local/cpanel/3rdparty/rmagic
    #637 686 4.0 0.7 9860 7680 ? RN Jan31 47:21 \\_ perl /usr/local/cpanel/3rdparty/rmagic/rmagic.pl /home/careerande

    The only thing I can think of that is different with this account is that it hasn\'t had a single hit in ages LOL

    So it\'s possible that rmagic.pl is hanging on accounts with empty logs?

    I\'ve deleted the account and recreated it hoping it will solve this problem.
     

Share This Page