The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RNDC Connect failed - Connect Refused

Discussion in 'General Discussion' started by p4martin, Mar 29, 2004.

  1. p4martin

    p4martin Registered

    Joined:
    Mar 9, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kitchener, Ont Canada
    Pretty new to this application, but all seemed ok until further testing.

    When I manually add a subdomain, after creating an account, all seems ok. I cannot however, create a domain on the fly.

    All goes well for the account creation, and then I get an error from bind:

    rndc connect failed, connection refused.

    The setup I am using:

    I do not need to create top level domains, only subdomains. Therefor.

    The local machine is the main dsn, and the campus nameservers are 2nd and 3rd. With authority passing down to local machine dns to resolve sub domain on the same server.

    Any thoughts:

    Do I have the configuration correct or have I missed something.

    Initial testing by manually creating a subdomain worked, traffic was passed to the new subdomain. If I create an account, nothing works. ALthough the account has been created
     
  2. HD-Sam

    HD-Sam Active Member
    PartnerNOC

    Joined:
    Sep 23, 2003
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Iowa City, Iowa
    Hello p4martin,
    Do a
    service named stop
    /scripts/fixndc
    service named start

    It may show rndc connection refused when you start.

    Just to make sure do another
    service named restart
    This time it shouldn't show that connection refused error.
     
  3. p4martin

    p4martin Registered

    Joined:
    Mar 9, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Kitchener, Ont Canada
    Seems a new error now

    I did as you suggested, alone with another fix mentioned in another thread.

    Changing rndc_key variable, and running the fix, twice. That did take away the connection error.

    Now however, I can create the new account, and no problems, script completes fine.

    Now I cant get the site in my browser. Unknow host cannot find server.

    Thinking I have a dns problem also, as one step in other fix, was to change the bind ver from 8, to 9 ( as using RH9 and 8 seems to default), the other was to disable the primary dns.

    I will activate this again, and see if the error goes. And I can get the site.

    Thanks for the quick reply. Muchly appreciated.
     
  4. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
Loading...

Share This Page