The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rndc: connection to remote host closed

Discussion in 'General Discussion' started by insekt, Sep 3, 2004.

  1. insekt

    insekt Member

    Joined:
    Jul 5, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    If im run 'rndc stop' or start server sats

    [root@host cpins]# rndc stop
    rndc: connection to remote host closed
    This may indicate that the remote server is using an older version of
    the command protocol, this host is not authorized to connect,
    or the key is invalid.

    or in cpanel

    Bind reloading on serv1 using rndc
    Error reloading bind on serv1: rndc: connection to remote host closed
    This may indicate that the remote server is using an older version of
    the command protocol, this host is not authorized to connect,
    or the key is invalid.



    Created DNS entry for planet.it-hosting.pl

    how fix it?

    Thank You:
    Dominik Nowacki
     
    #1 insekt, Sep 3, 2004
    Last edited: Sep 3, 2004
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Do a search on the forum as there are multiple threads regarding this problem. Some are OS specific.
     
  3. insekt

    insekt Member

    Joined:
    Jul 5, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Os = Redhat fedora 1
     
  4. AresXP

    AresXP Member

    Joined:
    May 26, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    That often happens with new servers.

    Login as "root" to SSH:

    Then do,
    /scripts/fixndc
    Then,
    pico /etc/named.conf

    Near the top, there's probably "rndc-key". Just remove the dash. (if there's no dashes, just follow the next step)

    Do CTRL+X then Y

    Then do
    service named restart

    That should do it :)
     
  5. insekt

    insekt Member

    Joined:
    Jul 5, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    key "zaq12wsx" {
    algorithm hmac-md5;
    secret "eCWWRhFVrc00mzz5QNmuSQ==";
    };


    controls {
    inet 127.0.0.1 allow { localhost; } keys { "zaq12wsx"; };
    };

    This is my /etc/named.conf (top)

    How im must change for repair it (im run fixndc and fixnamed
     
  6. insekt

    insekt Member

    Joined:
    Jul 5, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    please help me
     
  7. insekt

    insekt Member

    Joined:
    Jul 5, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    # Currently, you can use the following options:
    # ROOTDIR="/some/where" -- will run named in a chroot environment.
    # you must set up the chroot environment before
    # doing this.
    # OPTIONS="whatever" -- These additional options will be passed to named
    # at startup. Don't add -t here, use ROOTDIR instead.
    ROOTDIR=/var/named/chroot

    on all configs im say rndc-key in key value what me can ,make?
     
  8. AresXP

    AresXP Member

    Joined:
    May 26, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    if you do not have rndckey just do "service named restart" and you should be fine.
     
  9. AresXP

    AresXP Member

    Joined:
    May 26, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    btw, if this doesnt fix it, contact me on AIM, aresxp23.
     
Loading...

Share This Page