autolux

Member
Mar 11, 2010
8
0
51
Hi, i've been running centos with cloudlinux for my WHM server with PHP Selector for a while. However, i have a site on legacy PHP 5.2.x i need to run.

It is working kinda but some functionality is failing under PHP Selector 5.2 (or 5.1 or 5.3)...

Bringing up phpinfo it appears PHP Selector 5.2 uses PHP 5.2.17.

In my local xampp test environment, it does not work under 5.2.17 either... only PHP 5.2.3 seems to work correctly. how can I run this custom version under PHP selector?

looking at the docs;

CloudLinux Documentation

it would seem to be possible, but i'm not really sure about how to go about those instructions? any ideas?
 

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
Hi,

In my local xampp test environment, it does not work under 5.2.17 either... only PHP 5.2.3 seems to work correctly. how can I run this custom version under PHP selector?
The discussion to this would be more and it is better to consult a professional system administrator who can rebuild/build the required version of PHP for you and make it available for you with customizations in it..
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363