Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

root email delivery issue

Discussion in 'E-mail Discussion' started by Sander-Rob, Jul 8, 2008.

  1. Sander-Rob

    Sander-Rob Member

    Joined:
    Jul 4, 2008
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    51
    I'm setting up a new server, and have come across a problem.

    I have all email for the root user, being delivered to external-address@mydomain.com.

    This was working this morning, at which time the hostname was only the IP of the server.

    After this, I updated the hostname to webhost01.mydomain.com, and installed CSF. Since then, mail delivery for the root user does not work, and I'm getting the following errors (/var/log/exim_mainlog) when mail for root is trying to be delivered.

    I'm hoping someone can send me in the right direction.
     
  2. welo

    welo Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    156
    Am in pretty much the same boat. I'm not getting notified of anything (logwatch, cpupdate, BFD/LFD etc.). If I could just track down which file is being written when updating via 'Change System Mail Preferences' in WHM, I might be able to figure it out. Ideas?
     
  3. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    166
    Same problem here
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    166
    Same problem here
     
  5. Sander-Rob

    Sander-Rob Member

    Joined:
    Jul 4, 2008
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    51
    In the order specified, give this a shot.

    WHM >> Change System Mail Preferences

    Set Cpanel to "root"
    Nobody to Blank
    and root to "your e-mail address"
     
  6. jbourque

    jbourque Member

    Joined:
    Jul 18, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    It tried this and still no go. I have 2 servers configured them both the same way and my previous server works fine but my new server I just built does not work.

    Thoughts?
     
  7. jbourque

    jbourque Member

    Joined:
    Jul 18, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Figured it out, I had my 2nd server pointing to my main DNS server which did not have a dns entry for the new server therefore the email was not routing properly.
    :D
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice