The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

root@hostname cannot send mail

Discussion in 'E-mail Discussions' started by persiasoft, Oct 24, 2005.

  1. persiasoft

    persiasoft Active Member

    Joined:
    Nov 15, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    root@hostname cannot send mail for Root/cPanel notification mails

    how to resolve?

    every day i have more than 1000 msg. in Queue how to resolve this ?
     
  2. cbwass

    cbwass Well-Known Member

    Joined:
    Mar 29, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Have you configured 'Change System Mail Preferences' under 'Server Contacts' in WHM to tell WHM where to send the mail for Root?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should also tail your exim mainlog and then force delivery of one of those messages in the queue through WHM and watch for errors.
     
  4. persiasoft

    persiasoft Active Member

    Joined:
    Nov 15, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    i did this

    2005-10-23 04:02:12 1ETJ3y-0005Nd-KC == linux@somedomain.com routing defer (-51): retry time not reached

    i can send email via all smtps to linux@somedomain.com but not from this server,

    also my server is an open relay ( found from dnsreport.com ) how to resolve this ?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you have the standard cPanel configuration without any additional ACL's (e.g. if you run /scripts/reseteximtodefaults) then you won't have an open relay no matter what dnsreport.com says. If you have made ACL and other setting changes in exim.conf try resetting back to defaults and test it again.

    Those errors don't help as they didn't force a redelivery of the mail, you could try and find the orignal reason for it being queued with:

    grep 1ETJ3y-0005Nd-KC /var/log/exim_mainlog
     
Loading...

Share This Page