root @ hostname emails are frozen

WorkinOnIt

Well-Known Member
Aug 3, 2016
195
28
28
UK
cPanel Access Level
Root Administrator
Hello

I can't seem to get delivery of system emails.

I have configured WHM >> Home »Server Contacts »Edit System Mail Preferences.
  • The system currently forwards mail for “nobody” to “root”.
  • The system currently forwards mail for “root” to “[email protected]”.
  • The system currently forwards mail for “cpanel” to “root”.
I have CSF installed.

I have checked root/forward and it is showing the correct email "[email protected]"

In the mailqueue I see many frozen emails.

Output of exim

Code:
2016-08-30 02:45:48 cwd=/etc/csf 4 args: /usr/sbin/sendmail -f root -t
2016-08-30 02:45:48 1beNoq-0002Ca-Th <= [EMAIL][email protected][/EMAIL] U=root P=local S=666 T="lfd on myvps.myhostname.com: WHM/cPanel root access alert from xx.xx.xxx.xxx" for root
2016-08-30 02:45:48 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1beNoq-0002Ca-Th
2016-08-30 02:45:49 1beNoq-0002Ca-Th ** [EMAIL][email protected][/EMAIL] R=fail_remote_domains: The mail server could not deliver mail to [EMAIL][email protected][/EMAIL].  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
2016-08-30 02:45:49 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1beNoq-0002Ca-Th
2016-08-30 02:45:49 1beNor-0002Cf-4q <= <> R=1beNoq-0002Ca-Th U=mailnull P=local S=2133 T="Mail delivery failed: returning message to sender" for [EMAIL][email protected][/EMAIL]
2016-08-30 02:45:49 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1beNor-0002Cf-4q
2016-08-30 02:45:49 1beNoq-0002Ca-Th Completed
2016-08-30 02:45:49 1beNor-0002Cf-4q ** [EMAIL][email protected][/EMAIL] R=fail_remote_domains: The mail server could not deliver mail to [EMAIL][email protected][/EMAIL].  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
2016-08-30 02:45:49 1beNor-0002Cf-4q Frozen (delivery error message)
2016-08-30 02:46:24 cwd=/usr/local/cpanel/whostmgr/docroot 2 args: /usr/sbin/exim -bpra


And a sample of the frozen email;



Code:
Date:

Tue, 30 Aug 2016 02:45:44 +1200
From:
Mail Delivery System <[email protected]>
To:
[EMAIL][email protected][/EMAIL]
Subject:
Mail delivery failed: returning message to sender
--1472481944-eximdsn-949534470
Content-type: text/plain; charset=us-ascii

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  [EMAIL][email protected][/EMAIL]
    The mail server could not deliver mail to [EMAIL][email protected][/EMAIL].  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

--1472481944-eximdsn-949534470
Content-type: message/delivery-status

Reporting-MTA: dns; myvps.myhostname.com

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0

--1472481944-eximdsn-949534470
Content-type: message/rfc822

Return-path: <[email protected]>
Received: from root by myvps.myhostname.com with local (Exim 4.87)
    (envelope-from <[email protected]>)
    id 1beNol-0002C7-Q0
    for [EMAIL][email protected][/EMAIL]; Tue, 30 Aug 2016 02:45:43 +1200
To: [EMAIL][email protected][/EMAIL]
Subject: lfd on myvps.myhostname.com: Excessive resource usage: USERABC (2266 (Parent PID:1697))
From:  <[email protected]>
Message-Id: <[email protected]>
Date: Tue, 30 Aug 2016 02:45:43 +1200

Time:         Tue Aug 30 02:45:43 2016 +1200
Account:      userabc
Resource:     Process Time
Exceeded:     5404 > 1800 (seconds)
Executable:   /usr/bin/php
Command Line: /usr/bin/php
PID:          2266 (Parent PID:1697)
Killed:       No
Any assistance appreciated.
 

Infopro

Well-Known Member
May 20, 2003
17,113
511
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Make sure you're using a valid off server email address in these forms:
WebHost Manager »Server Contacts »Edit System Mail Preferences

A gmail account is not a great idea to use here as too many emails from your server to gmail will get them rate limited or even blocked.
 

WorkinOnIt

Well-Known Member
Aug 3, 2016
195
28
28
UK
cPanel Access Level
Root Administrator
Yes, but that is not the issue here. The emails are not even getting sent.

I've also looked at /root/.forward file and the email in there is correct
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello,

Could you verify if the hostname is missing from the /etc/localdomains file on the affected system? If so, adding the server's hostname to this file should address the issue.

Thank you.
 

WorkinOnIt

Well-Known Member
Aug 3, 2016
195
28
28
UK
cPanel Access Level
Root Administrator
Hello Michael

The hostname, let's say is: myvps.myhostname.com which has been set in Home »Networking Setup »Change Hostname

Current Hostname
myvps.myhostname.com
I've checked the file /etc/localdomains and myhostname.com is listed. Do I also need to add an entry for myvps.myhostname.com ?
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello,

The hostname is automatically added /etc/localdomains during the initial cPanel installation and anytime the hostname is changed. Could you verify if you manually changed the hostname at some point instead of using the "WHM >> Change Hostname" feature?

Thank you.
 

WorkinOnIt

Well-Known Member
Aug 3, 2016
195
28
28
UK
cPanel Access Level
Root Administrator
No - I did not manually change anything - I used WHM all the way. but the hostname was missing from /etc/localdomains

I am using a cPanel ISO snapshot from my cloud provider. I have noticed a few irregular entries here and there.

I think I had better start with a fresh install next time. However, I did upgrade cPanel as a first job when getting started. I suppose it's possible any custom changes were not overwritten.

Anyway - this problem is solved.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
I'm happy to see the issue is now resolved. You may also want to report the issue to your cloud provider so they can review the snapshop offered and make any corrections.

Thank you.