Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

root mail delivery failed

Discussion in 'E-mail Discussion' started by k2tec, Feb 3, 2016.

  1. k2tec

    k2tec Well-Known Member

    Joined:
    Aug 26, 2011
    Messages:
    98
    Likes Received:
    3
    Trophy Points:
    58
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    All other mail from root are being send, but not the /usr/local/cpanel/scripts/upcp --cron" for root.
    Code:
    root@vps [~]# exim -bt root@*****.com
    root@*****.com is undeliverable: The mail server could not deliver mail to root@*****.com.  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,303
    Likes Received:
    1,847
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify if the "root" forwarder is configured to forward to a valid email address? It's modified via:

    "WHM Home » Server Contacts » Edit System Mail Preferences"

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. k2tec

    k2tec Well-Known Member

    Joined:
    Aug 26, 2011
    Messages:
    98
    Likes Received:
    3
    Trophy Points:
    58
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    I tried :
    Forward mail for “root” to:me@minedomein.com
    The system currently forwards mail for “nobody” to root and me@minedomein.com
    The system currently forwards mail for “cpanel” to root and me@minedomein.com
    No luck
    It'only this mail /usr/local/cpanel/scripts/upcp --cron" for root.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,303
    Likes Received:
    1,847
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you verify if your domain name or your server's hostname are added to the /etc/remotedomains file? EX:

    Code:
    grep $domain /etc/localdomains /etc/remotedomains
    If so, ensure you move it to the /etc/localdomains file by changing the "Mail Routing" settings under "WHM >> DNS Functions >> Edit DNS Zone", assuming your email is handled locally.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. k2tec

    k2tec Well-Known Member

    Joined:
    Aug 26, 2011
    Messages:
    98
    Likes Received:
    3
    Trophy Points:
    58
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    Hi Michael,
    shows nothing

    But what I can see in WHM >> DNS Functions >> Edit DNS Zone
    All accounts are local
    Only when I look to my server name it shows nothing for my mail
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. k2tec

    k2tec Well-Known Member

    Joined:
    Aug 26, 2011
    Messages:
    98
    Likes Received:
    3
    Trophy Points:
    58
    Location:
    Netherlands
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    I think I got working.
    I edit the dnszone for my servername and when I test it with
    Code:
    root@vps [~]# exim -bt root@*****.com
    I get the right answer
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,303
    Likes Received:
    1,847
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice