SOLVED Root sending mail to root - System Mail Preferences not applied

web01

Member
Aug 5, 2019
5
2
3
Australia
cPanel Access Level
Root Administrator
My server frequently sends emails similar to the one in the attached image. They are from [email protected] to [email protected] and I am unsure what they represent.

I have updated all the email settings in server configuration and system mail preferences to a valid address and restarted but the issue persists.

Can someone tell me what the messages mean, and either how to send them to a working address or disable them?

Running CentOS 7, CLoud Linux 7, Litespeed and Cpanel v82.0.7 with root access.
 

Attachments

web01

Member
Aug 5, 2019
5
2
3
Australia
cPanel Access Level
Root Administrator
Thanks, the thing is that email address doesn't exist and I don't know why root is trying to send an email to itself and so often (see attached).

The issue is not why it isnt being delivered but why is it being sent and how can I stop it.

It seemed the system mail preferences being set to root was the solution but surprisingly no change after a restart.

The sender / recipient is [email protected] and there are no emails accounts associated with serverdomain.

No mail issues with any of the cPanel accounts, is this normal?
 

Attachments

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
It seemed the system mail preferences being set to root was the solution but surprisingly no change after a restart.
You've added "root" there instead of an off-server email address? This should be set to an email address. And that email address should work properly.
The domain in your screenshots shows an MX issue on intodns.com, I checked it.
 

web01

Member
Aug 5, 2019
5
2
3
Australia
cPanel Access Level
Root Administrator
You've added "root" there instead of an off-server email address? This should be set to an email address. And that email address should work properly.
The domain in your screenshots shows an MX issue on intodns.com, I checked it.
It was originally set to root I changed it to a valid email. The emails are still the same though.

Thanks for the tip on the domain issue will look inot it now that may have something to do with it.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello @web01,

The error you reported can sometimes happen if an entry for your hostname is missing from the /etc/localdomains file.

Can you confirm if your server's hostname exists in the /etc/localdomains file? You can run the following command to check:

grep `hostname` /etc/localdomains

If not, please update your hostname (you can keep the same name) using WHM >> Change Hostname and then run the above command again to verify if the hostname exists in that file.

Thank you.
 

web01

Member
Aug 5, 2019
5
2
3
Australia
cPanel Access Level
Root Administrator
@cPanelMichael Thanks for the tip, my hostname was in fact missing from that file and emails are now being delivered correctly from that address. Thanks for your assistance and thanks to @Infopro for the heads up on the mx issue which has also been rectified.
 
  • Like
Reactions: Infopro